Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox 96 - block autoplay still doesn't work

  • 6 trả lời
  • 1 gặp vấn đề này
  • 91 lượt xem
  • Trả lời mới nhất được viết bởi Frank & Jen

more options

I know it gets posted a lot but none have actual working answers. I have autoplay to be blocked on all sites, I will never want any site to autoplay anything, I'd rather not be ever to ever start the video than for autoplay to happen.

I've checked the about:config against other posts say are the answer but it it's never solved this.

Upgraded to firefox 96 and the problem persists - haven't checked much yet but instagram.com is certainly playing every post.

I know it gets posted a lot but none have actual working answers. I have autoplay to be blocked on all sites, I will never want any site to autoplay anything, I'd rather not be ever to ever start the video than for autoplay to happen. I've checked the about:config against other posts say are the answer but it it's never solved this. Upgraded to firefox 96 and the problem persists - haven't checked much yet but instagram.com is certainly playing every post.

Giải pháp được chọn

When you have that website loaded, you can launch the Page Info window with ctl+i, go to the Permissions tab then select Autoplay > Block Audio and Video.

In addition to the preferences mentioned by cor-el I have the following preference marked false but I don't remember where I got that information from. I never have autoplay problems. media.block-autoplay-until-in-foreground

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (7)

more options

I don't have an account so just post link examples of the issue.

Hữu ích?

more options

You can look at these prefs on the the about:config page to see what settings work for you to block autoplay.

  • media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Hữu ích?

more options

As I mentioned we've checked all those setting every version a ton of times and it stops autoplay on some sites but far from all.

Hữu ích?

more options

Do you have an example of a website where autoplay blocking is not working for you?

Hữu ích?

more options

Giải pháp được chọn

When you have that website loaded, you can launch the Page Info window with ctl+i, go to the Permissions tab then select Autoplay > Block Audio and Video.

In addition to the preferences mentioned by cor-el I have the following preference marked false but I don't remember where I got that information from. I never have autoplay problems. media.block-autoplay-until-in-foreground

Hữu ích?

more options

Here is an example of where autoplay blocking is not working:

   https://www.marketwatch.com/latest-news?mod=top_nav

There is an "AdChoices" ad on the right side near the top next to "Latest News". Note: Avoid scrolling down too far as a subscription restriction may kick in. I have set, just left of the URL: Autoplay = Block audio and Video. I haven't changed any dangerous config settings as of yet. I want autoplay blocked on this site, not all sites.

Hữu ích?

more options

TNorth said

When you have that website loaded, you can launch the Page Info window with ctl+i, go to the Permissions tab then select Autoplay > Block Audio and Video.

This doesn;t help, everything i see still shows as autoplay is being blocked.


In addition to the preferences mentioned by cor-el I have the following preference marked false but I don't remember where I got that information from. I never have autoplay problems. media.block-autoplay-until-in-foreground

This seems like it's helping, very poor naming for the setting, doesn't seem intuitive nor should it be set to true by default when you use normal setting to block autoplay.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.