Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Website options don't work for Firefox

  • 9 trả lời
  • 1 gặp vấn đề này
  • 11 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I've logged into consumerreports.org and am looking at refrigerators and am trying to set a filter based on "Categories" (see jpg image) At this point no input is accepted other than 'Accept'. I can not clear or change any selection. This same condition occurs with all the other options.

When I use Chrome this conditions does not occur. I can set any filter, save it, and see the result.

Is there some Firefox setting that controls this behavior that I can change?

I've logged into consumerreports.org and am looking at [https://www.consumerreports.org/products/refrigerators-28978/french-door-refrigerator-37162/view2/ refrigerators] and am trying to set a filter based on "Categories" (see jpg image) At this point no input is accepted other than 'Accept'. I can not clear or change any selection. This same condition occurs with all the other options. When I use Chrome this conditions does not occur. I can set any filter, save it, and see the result. Is there some Firefox setting that controls this behavior that I can change?
Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Here's a screenshot of that dialog for reference (page requires login):

If you check a size box, All should be cleared/un-checked. And if you check All, the others should be cleared/un-checked. Sounds like that isn't working.

Regarding the visual difference, I think your Firefox is applying the Windows 7 High Contrast Dark theme to the page. I don't know whether that is relevant to the problem if checkboxes on other sites work normally. If you want to test with High Contrast disabled, this article has the steps: Disable high contrast mode in Firefox.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (9)

more options

I could not find the filter your screenshot shows. I think one needs to log in.


Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Hữu ích?

more options

@FredMcD The site needs to be logged on. I just checked the 'Shield' and Consumer Reports has two social media trackers and one cross platform tracker. I'd like to experiment. If I turn protection off, experiment, and then turn protection on. ill the trackers be deleted/inhibited when protection is turned on? thanks

Hữu ích?

more options

Giải pháp được chọn

Here's a screenshot of that dialog for reference (page requires login):

If you check a size box, All should be cleared/un-checked. And if you check All, the others should be cleared/un-checked. Sounds like that isn't working.

Regarding the visual difference, I think your Firefox is applying the Windows 7 High Contrast Dark theme to the page. I don't know whether that is relevant to the problem if checkboxes on other sites work normally. If you want to test with High Contrast disabled, this article has the steps: Disable high contrast mode in Firefox.

Hữu ích?

more options

@jscher2000 The issue is resolved by removing the HIgh-Contrast Mode. Any work-around so the I can use High-Contrast?

Hữu ích?

more options

Works for me without a login, I only need to switch to View -> Full View

If I select 'All' then the choices under it are cleared automatically and vice versa if I select one or more of the others then 'All' gets cleared unlike what your screenshot shows where 'All' is selected and others too, so it looks like the checkboxes aren't updated properly.


Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Hữu ích?

more options

slipbits said

@jscher2000 The issue is resolved by removing the HIgh-Contrast Mode. Any work-around so the I can use High-Contrast?

Unfortunately, I don't have Windows 7 to test with any more, so I don't have any insight into why the checkboxes don't uncheck with the High Contrast system theme.

Did you ever set browser.proton.enabled to false in about:config? That caused problems with checkboxes always appearing to be checked on the Settings page a while back, but I don't know whether that could be a factor.

Hữu ích?

more options

@cor-el Nope. None of the choices worked. The issue continued in troubleshoot mode. The only answer with works is the one suggested by @FredMcD. But, "Troubleshoot mode' is neat. I will use it in the future. thanks

Hữu ích?

more options

@FredMcD Nope. No change with proton.enabled = false.

Hữu ích?

more options

Note that browser.proton.enabled should be true (default), having it set to false can cause issues.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.