Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox automatically running Dark mode after updating to 96.0 (64-bit)

  • 2 trả lời
  • 4 gặp vấn đề này
  • 117 lượt xem
  • Trả lời mới nhất được viết bởi a.sin

more options

My browser updated to 96.0 (64-bit) about an hour ago. I've been running the Cheshire cat Theme for a long time now without it making the entire browser turn Dark (I just like what it did to the Tab bar and the Menu Bar). It didn't effect anything else -- not the Menus themselves and certainly not any webpages. But since the update--the Menus, the Firefox Home page, the Settings page, and even the Google search results pages--all have been showing up in Dark Mode. I switched around other themes I have and noticed that only the themes that are light in color stop everything from going dark.

It's a minor thing but I would really like to keep my set up as it was. I would really appreciate some help.

My browser updated to 96.0 (64-bit) about an hour ago. I've been running the Cheshire cat Theme for a long time now without it making the entire browser turn Dark (I just like what it did to the Tab bar and the Menu Bar). It didn't effect anything else -- not the Menus themselves and certainly not any webpages. But since the update--the Menus, the Firefox Home page, the Settings page, and even the Google search results pages--all have been showing up in Dark Mode. I switched around other themes I have and noticed that only the themes that are light in color stop everything from going dark. It's a minor thing but I would really like to keep my set up as it was. I would really appreciate some help.

Giải pháp được chọn

a.sin said

I've been running the Cheshire cat Theme for a long time now without it making the entire browser turn Dark (I just like what it did to the Tab bar and the Menu Bar). It didn't effect anything else -- not the Menus themselves and certainly not any webpages. But since the update--the Menus, the Firefox Home page, the Settings page, and even the Google search results pages--all have been showing up in Dark Mode. I switched around other themes I have and noticed that only the themes that are light in color stop everything from going dark.

A search turned up 81 possible Cheshire Cat themes, but I'm assuming the problem is one that has a darker background and lighter text.

Firefox 95+ is taking more and more cues from your toolbar area theme for how to style other aspects of the browser. There is a setting for some of these, but not all of them.

(A) Right-click context menus, toolbar drop-down panels

Starting in Firefox 89, these would flip to a dark background if the text on the inactive/background tabs was white or light. Firefox 96 has extended this adaptation to more parts of the browser. As far as I know, the only built-in way to avoid this is to change your toolbar theme to one with dark text on the inactive/background tabs. (The other way is the not-officially-supported userChrome.css file route.)

(B) Built-in pages, and websites that have light/dark responsive themes

Starting in Firefox 95, Firefox would inform pages that you preferred a light/dark theme based on your Firefox toolbar theme instead of your system theme. There is a way to decouple your page (content) theme preference from your toolbar theme. At this point, it's only available through the back door...

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.


I have attached a composite screenshot of what Firefox 96 considers a "Dark" theme (light text) and a "Light" theme for reference. It's difficult to say exactly where that line is, as I'm sure your experimentation demonstrated.

Đọc câu trả lời này trong ngữ cảnh 👍 2

Tất cả các câu trả lời (2)

more options

Giải pháp được chọn

a.sin said

I've been running the Cheshire cat Theme for a long time now without it making the entire browser turn Dark (I just like what it did to the Tab bar and the Menu Bar). It didn't effect anything else -- not the Menus themselves and certainly not any webpages. But since the update--the Menus, the Firefox Home page, the Settings page, and even the Google search results pages--all have been showing up in Dark Mode. I switched around other themes I have and noticed that only the themes that are light in color stop everything from going dark.

A search turned up 81 possible Cheshire Cat themes, but I'm assuming the problem is one that has a darker background and lighter text.

Firefox 95+ is taking more and more cues from your toolbar area theme for how to style other aspects of the browser. There is a setting for some of these, but not all of them.

(A) Right-click context menus, toolbar drop-down panels

Starting in Firefox 89, these would flip to a dark background if the text on the inactive/background tabs was white or light. Firefox 96 has extended this adaptation to more parts of the browser. As far as I know, the only built-in way to avoid this is to change your toolbar theme to one with dark text on the inactive/background tabs. (The other way is the not-officially-supported userChrome.css file route.)

(B) Built-in pages, and websites that have light/dark responsive themes

Starting in Firefox 95, Firefox would inform pages that you preferred a light/dark theme based on your Firefox toolbar theme instead of your system theme. There is a way to decouple your page (content) theme preference from your toolbar theme. At this point, it's only available through the back door...

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.


I have attached a composite screenshot of what Firefox 96 considers a "Dark" theme (light text) and a "Light" theme for reference. It's difficult to say exactly where that line is, as I'm sure your experimentation demonstrated.

Hữu ích?

more options

Thank you jscher2000. Changing the Configuration to 1 brought Cheshire back. And yes, the toolbar is black on this theme. The toolbar drop-down panels are still dark but the rest has gone back to how it was. At least now I know it wasn't something I did. I did check the "What's New" page for the update but it didn't mention anything about this layout change. Anyways, thank you very much for your help.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.