On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

My Firefox suddenly frozen on Linux many times.

  • 15 trả lời
  • 1 gặp vấn đề này
  • 71 lượt xem
  • Trả lời mới nhất được viết bởi Alberto

more options

When I'm using my Firefox for too long or few couple of minutes its suddenly fronzen and stops response. So I need to restart it, killing the process using top,htop or kill commands. It has been weeks that this problem started. I waited for updates and tried reinstall it, but no futher SO updates and reinstall solved the problem, if the new Firefox release updates could put a end to this problem.

I have here some ID number of my bug report that I send to Mozilla, if someone could help understand if its a package/driver or miss configuration I would like to know.

bp-8764ac27-aa1c-4db5-831c-ae2460211031 bp-87b0281c-aae3-418e-8f45-828f20211031 bp-d01fcb65-6123-499a-a3d8-4c7950211031 bp-83d56e36-0d58-4456-a7e5-677370211031 bp-a385f497-2271-4120-bdbb-474440211031 bp-f320a744-5606-4743-87ab-763620211031 bp-4a2d704e-cf83-4eb5-8df0-c10b70211031

When press the upper right button 'x' to close, it says that my Firefox isn't respond due to: 'Firefox: Exiting due to channel error'

I don't know how to fix it or find better logs messages to discover what is happens on the Firefox. I have SO with Windows 10 and I don't have this problem at all.

When I'm using my Firefox for too long or few couple of minutes its suddenly fronzen and stops response. So I need to restart it, killing the process using top,htop or kill commands. It has been weeks that this problem started. I waited for updates and tried reinstall it, but no futher SO updates and reinstall solved the problem, if the new Firefox release updates could put a end to this problem. I have here some ID number of my bug report that I send to Mozilla, if someone could help understand if its a package/driver or miss configuration I would like to know. bp-8764ac27-aa1c-4db5-831c-ae2460211031 bp-87b0281c-aae3-418e-8f45-828f20211031 bp-d01fcb65-6123-499a-a3d8-4c7950211031 bp-83d56e36-0d58-4456-a7e5-677370211031 bp-a385f497-2271-4120-bdbb-474440211031 bp-f320a744-5606-4743-87ab-763620211031 bp-4a2d704e-cf83-4eb5-8df0-c10b70211031 When press the upper right button 'x' to close, it says that my Firefox isn't respond due to: 'Firefox: Exiting due to channel error' I don't know how to fix it or find better logs messages to discover what is happens on the Firefox. I have SO with Windows 10 and I don't have this problem at all.

Giải pháp được chọn

Seem that the problem stopped from now. I don't know exactly what was, but I normally install my codecs following this page: https://en.opensuse.org/SDB:Installing_codecs_from_Packman_repositories

And I know that they get the packages from Packman repository. I had reinstalled it before even doing a new OpenSuse fresh installation.

Now with the new updates seems everything is running well.


I'm glad that everything is running smoothly now.


For anyone with the same problem just wait for updates and try to reinstall the codecs.


If the problem appear again I will open a new topic.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (15)

more options

Hey Alberto, Try Firefox Troubleshoot Mode to see if the problem goes away. Firefox Troubleshoot Mode (previously known as Firefox Safe Mode) is a special diagnostic mode that temporarily turns off hardware acceleration, disables add-ons (extensions and themes) and resets some settings. See the Diagnose Firefox issues using Troubleshoot Mode article for details.

If Firefox is open, you can restart in Firefox Troubleshoot Mode from the Help menu:

  • Click the menu button Fx57Menu, click Help, select Troubleshoot Mode and click Restart in the "Restart Firefox in Troubleshoot Mode?" dialog that opens.

If Firefox is not running, you can start Firefox in Troubleshoot Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Troubleshoot Mode window appears, select "Open".

Fx88TroubleshootMode

If the issue is not present in Firefox Troubleshoot Mode, your problem is probably caused by an extension, theme or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Troubleshoot Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again. (If you can't exit Firefox Troubleshoot Mode, please see Firefox is stuck in Troubleshoot Mode).

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Also, try downloading a separate copy of Firefox and run it from the folder(do not sign into you Firefox account) to see what happens.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

more options

I will Test your advices and I will come back later with the results. Until now I could get another log message from terminal when I use: 'firefox & ' command to run on the background:

      1. !!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost


Thanks,

I will check your advices.

more options

I checked the bug reports. Looks like the issue is related to Widevine. Could you try and disable the plugin and check whether the issue persists?

more options

I run the Firefox on Safe mode on my Linux SO OpenSuse and the problem still there. I know that the problem will come when the Youtube video stops running and from there just need open more tabs or websites and them my Firefox frozens. Sometimes also frozen without Youtube video.

From my last try with Safe Mode I got this message from my terminal:

[Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c04f76c00 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c04f76c00 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c0842d800 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c0842d800 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf8a69000 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf8a69000 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c0316d000 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c0316d000 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c031bc800 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c031bc800 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c0842a000 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c0842a000 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf3e0c000 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf3e0c000 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf4b50400 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf4b50400 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf4b81c00 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf4b81c00 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf4b8c800 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf4b8c800 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf3e0f800 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf3e0f800 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf8a60400 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf8a60400 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c0127f800 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c0127f800 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c01d18800 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c01d18800 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf4b89c00 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5bf4b89c00 Decode error: NS_ERROR_DOM_MEDIA_DEMUXER_ERR (0x806e000c) - virtual RefPtr<mozilla::MozPromise&lt;mozilla::MediaResult, mozilla::MediaResult, true&gt; &gt; mozilla::MP4Demuxer::Init(): No MP4 audio () or video () tracks: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:3541 [Child 26833, MediaDecoderStateMachine #1] WARNING: Decoder=7f5c02e67c00 state=DECODING_METADATA Decode metadata failed, shutting down decoder: file /home/abuild/rpmbuild/BUILD/firefox-93.0/dom/media/MediaDecoderStateMachine.cpp:366 </p>

more options

I'm testing now the Widevine plugin.

more options

I am watching this. In my case of slowness or stalling, moving my large amount of bookmarks to subfolders helped somewhat. I still had problems, but not as frequently. Just like having too many files in a single folder can drastically slow down a computer, having too many bookmarks in the initial folder may do the same. I have thousands upon thousands of bookmarks.

more options

I will take note of this @rjt69.

For now I will just format my OpenSuse with a new installation.

Until now the problem persists even with Safe Mode, I didn't try to install it by the tar.gz that @ jonzn4SUSE said. But if after the Opensuse Reinstallation didn't end this I will try the tar.gz install.

more options

edpicubit said

I checked the bug reports. Looks like the issue is related to Widevine. Could you try and disable the plugin and check whether the issue persists?

The Widevine stopped the problem with Firefox frozen at all, but didn't stopped the problem with youtube or any other sites that use media videos, the keep loading eternally without playing the video.

more options

Make sure you have the latest FFmpeg and libavcodec packages installed.

You can toggle DRM off/on to make Firefox (re)load DRM components.

You should see a XHR request in the Browser Console.

more options

If you want to dig for the issue try strace. see screenshots

more options

I only use the distro version of Firefox as a backup(bookmarks and tabs) to Nightly(my daily driver). I also run a separate copy, but same or close to the version from the distro to test. see screenshot of versions currently running from folders the Download directory.

Được chỉnh sửa bởi jonzn4SUSE vào

more options

cor-el said

Make sure you have the latest FFmpeg and libavcodec packages installed. You can toggle DRM off/on to make Firefox (re)load DRM components. You should see a XHR request in the Browser Console.

I'm on Tumbleweed, here is a must have site for openSUSE.

One-Click-Installers for openSUSE Multimedia Codecs: https://opensuse-community.org/

Here is a shot of the latest FFmpeg and libavcodec packages installed.

Được chỉnh sửa bởi jonzn4SUSE vào

more options

cor-el disse

Make sure you have the latest FFmpeg and libavcodec packages installed. You can toggle DRM off/on to make Firefox (re)load DRM components. You should see a XHR request in the Browser Console.

I will check it again.


jonzn4SUSE disse

If you want to dig for the issue try strace. see screenshots

I'm checking all your advices there.


Until now, I had done a new fresh installation of OpenSuse Tumbleweed and I still have the same problems. Seems to me that the codecs and DRM or XHR are causing the problem.

I will update it more. I had check over the internet before post it here. But the answers about he problem are very scarce.

more options

Giải pháp được chọn

Seem that the problem stopped from now. I don't know exactly what was, but I normally install my codecs following this page: https://en.opensuse.org/SDB:Installing_codecs_from_Packman_repositories

And I know that they get the packages from Packman repository. I had reinstalled it before even doing a new OpenSuse fresh installation.

Now with the new updates seems everything is running well.


I'm glad that everything is running smoothly now.


For anyone with the same problem just wait for updates and try to reinstall the codecs.


If the problem appear again I will open a new topic.