Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox causes 100% CPU usage when opening couple tabs at the same time!!!

  • 21 trả lời
  • 1 gặp vấn đề này
  • 46 lượt xem
  • Trả lời mới nhất được viết bởi empleat

more options

I Am on desktop:

i5 9600KF (high performance mode) 16GB 3200mhz ram NVME... Windows 10 Pro x64 Firefox last stable

When I open Firefox tabs aren't loaded all at the same time, but they are suspended. So after that: when I switch between 6 tabs quickly - they start to open at the same time. And CPU usage skyrockets to 100% LOL! Given I Am on high end PC - this is joke! I was using chrome and had hundreds of tabs and Chrome doesn't even suspend them by default. They open all at the same time I think!

So there is something wrong! I tried troubleshooting mode and it was the same problem!

Thanks for help!

Tất cả các câu trả lời (20)

more options

I tested by visiting every tab in this window, 14 of which hadn't been loaded yet after the Firefox 92 update. CPU use went to 100% for maybe 10-15 seconds, and then returned to baseline. Here's the graph:

Of course, the strain probably depends on the specific pages involved, but I'm not getting a hair-on-fire three-exclamation-point feeling about this.

Hữu ích?

more options

[quote] But I'm not getting a hair-on-fire three-exclamation-point feeling about this. /quote

What do you mean? This is not normal, 6 tabs shouldn't load so slowly and shouldn't max whole i5 9600KF!!! I used to open on Chrome hundreds of tabs at start and it took just couple seconds... 6 youtube tabs BTW.

Được chỉnh sửa bởi empleat vào

Hữu ích?

more options

Hữu ích?

more options

empleat said

This is not normal, 6 tabs shouldn't load so slowly and shouldn't max whole i5 9600KF!!! I used to open on Chrome hundreds of tabs at start and it took just couple seconds... 6 youtube tabs BTW.

How slowly? It's possible that Firefox can't load YouTube from cache and needs to retrieve the pages again. I generally don't keep YouTube tabs open, so I don't have a reference point for that, just the test results I gave you.

Hữu ích?

more options

FredMcD said

Start Firefox using Troubleshoot(Safe) Mode {web link} A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there? https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

As I said: I tried troubleshooting mode already - same problem :(

jscher2000 said

empleat said

This is not normal, 6 tabs shouldn't load so slowly and shouldn't max whole i5 9600KF!!! I used to open on Chrome hundreds of tabs at start and it took just couple seconds... 6 youtube tabs BTW.

How slowly? It's possible that Firefox can't load YouTube from cache and needs to retrieve the pages again. I generally don't keep YouTube tabs open, so I don't have a reference point for that, just the test results I gave you.

Extremely slowly: it takes couple seconds. Besides even single tab cause CPU usage go to 80% and loads like 3 seconds.. While 6 tabs like 6 seconds.

Hữu ích?

more options

Maybe it's this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1724980

Can you try to test it in the Nightly version?

Hữu ích?

more options

On nightly usage is slightly less: 60-80% but tabs open still slowly!!! What is that bug BTW? I don't see solution there!

Được chỉnh sửa bởi empleat vào

Hữu ích?

more options

92.0.1 problem still exists, any ideas ???

Hữu ích?

more options

Hi empleat!

How many browser extensions/add-ons do you have? Can you list them? Many interact with YouTube so it's possible one is the culprit.

Side note: I'm not surprised YouTube links are loading more quickly in Chrome. Google owns both and I have a feeling YT is integrated into Chrome by default (aka, it preloads video DLLs). This is all speculation though, I haven't tested.

Hữu ích?

more options

RoyDA said

Hi empleat! How many browser extensions/add-ons do you have? Can you list them? Many interact with YouTube so it's possible one is the culprit. Side note: I'm not surprised YouTube links are loading more quickly in Chrome. Google owns both and I have a feeling YT is integrated into Chrome by default (aka, it preloads video DLLs). This is all speculation though, I haven't tested.

Nope that's not it! I tried nightly build = same issue, also clean boot, start Firefox in troubleshooting mode, general tips on Firefox support site for high cpu usage, safe mode networking. No background programs! I Am now on FF 92.0.1 - same issue!

Slowness is not exclusive on youtube unfortunately and tabs load very slowly, just 6 tabs maxes CPU on 100% while they load slowly....

Hữu ích?

more options

Can you post a comparison screenshot of the Windows 10 Task Manager Performance tab showing the performance with restoring your tabs? For reference, mine was attached to this reply: https://support.mozilla.org/en-US/questions/1349711#answer-1441369

Hữu ích?

more options

OK.....

Hữu ích?

more options

Thanks. Looks like about 15 seconds of higher CPU utilization to restore 6 tabs with a brief spike to 100%. With my slower system, restoring 14 tabs caused a much longer spike to 100%.

I don't know what is involved in restoring a tab, so I don't have an opinion on whether this is reasonable. Do you want to file a bug report? https://bugzilla.mozilla.org/

Hữu ích?

more options

Yeah probably should do that. zzzzzzzzz...

Hữu ích?

more options

jscher2000 said

Thanks. Looks like about 15 seconds of higher CPU utilization to restore 6 tabs with a brief spike to 100%. With my slower system, restoring 14 tabs caused a much longer spike to 100%. I don't know what is involved in restoring a tab, so I don't have an opinion on whether this is reasonable. Do you want to file a bug report? https://bugzilla.mozilla.org/

Bugzilla says: it is not a bug, after checking a profile record. Hmmm... It is strange, because I Am using 2 Mozilla instances, it was happening in both (including one with small amount of tabs) but now since v 93.0, it doesn't happen there. However it is still happening in my main instance! But even in instance, when it doesn't max CPU to 100%, 6 tabs cause still 53% CPU usage, which doesn't seem great, at least they load instantly!

Được chỉnh sửa bởi empleat vào

Hữu ích?

more options

Now issue doesn't happen with only 6 tabs in my main window, while it was previously happening in 3 different profiles of Firefox! That is after Firefox 93.0. But performance in my main windows where I have 800 tabs is still piss poor. It used to be fine with 1000 tabs... So I Am leaving Firefox, I can't work like this sadly...

Được chỉnh sửa bởi empleat vào

Hữu ích?

more options

Part of the problem may be your internet service provider. Opening multiple tabs can create an overload on your downloaded data via the ISP, especially if you use satellite service.

Hữu ích?

more options

How would that be related to 100% CPU usage, besides I have 150mb/s cable! Never had problems with my ISP over 10 years!

Hữu ích?

more options

My apologies for attempting to help. It won't happen any more. Have a great day and good luck.

Hữu ích?

more options

Bud said

My apologies for attempting to help. It won't happen any more. Have a great day and good luck.

LOL you are crazy. I merely said that is not problem. OK I will lie and talk to you next hour about imaginary problem. What Am I supposed to say.

Today people are so sensitive, we are just talking facts... I don't understand what is going oN?

Hữu ích?

  1. 1
  2. 2
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.