Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Unable to setup Firefox as default browser in my iMac desktop.

  • 6 trả lời
  • 1 gặp vấn đề này
  • 21 lượt xem
  • Trả lời mới nhất được viết bởi Bithiah

more options

My setup:

  • FireFox: Version 89 for Mac
  • macOS Big Sur - Version 11.5.2
  • Only other Browser is "Safari"
  • Mac is only a few months old and fully setup by for me by Apple Support before purchase.

It does NOT matter what I have done to set Firefox as default, it is being required to be set up as though it is the first time every time I start up my Mac.

  • I have tried the following:

- System Preferences General, Set Default web browser as "Firefox" - this does show 'Firefox' as the default browser - Within Firefox, Preferences,General, Set FireFox as the Default Browser - this does show Firefox as the Default Browser - When the above did NOT seem to make any difference, 'Refreshed Firefox' - I also setup Firefox Options to "start up at Login" all the time.

NO luck. Currently living with the issue by opening Firefox every time I log in. Not sure what else I can do.

Giải pháp được chọn

Hey there!

If your problem is solved, please mark a solution so that others can see this thread is solved. Thank you in advance!

Kind regards,

Bithiah

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (6)

more options

Hey there!

Please view the following links on how to setup Firefox as your default browser:

https://support.mozilla.org/en-US/kb/setting-firefox-default-browser-does-not-work https://support.mozilla.org/en-US/kb/make-firefox-your-default-browser

I have using my iMac (Retina 4K, 21.5-inch, 2017) and I just followed the steps in the links above and it works! :)

Hope I helped!

Kind regards,

Bithiah

Hữu ích?

more options

Tuesday the 24th August 2021, 8 am

Hi Bithiah,

Thank you for trying to help me.

In fact, I had already tried to do exactly what you have referred to and it did NOT work. However, I did try again what you have suggested and have had NO success (both thru Safari and thru FireFox Preferences).

Every time, I start my Mac ( I switch the Mac off at night and restart again every morning), the default of Firefox is being rest to "Safari". I have to start Firefox by clicking "Open" and that is how I am managing now.

It is as if my Mac OS Operating system simply forgets it completely OR it resets it OR something else - I am NOT sure.

Shiva

Hữu ích?

more options

Hey there!

Please see the screenshots below. Make sure you've checked them as Firefox and your somputer should recongnise that Firefox is your main browser.

For the first image, go to about:preferences on a new tab (and click enter) then make sure your default browser is firefox is tick marked.

For the second image, got to Systems Preferences --> General and go down to where it says Default Browser and make sure you choose Firefox.

If it still doesn't work, try contacting Apple support.

See also : https://support.apple.com/en-au/HT201607

Hope I helped!

Kind regards,

Bithiah

Hữu ích?

more options

Hey there!

Please see the screenshots below.

For the first image, go to about:preferences on the search bar (and press enter). Then make sure that you've check the box which says Always check if Firefox is your main browser.

For the second image, got to Systems Preferences --> General and scroll down for Default Browser and choose Firefox.

If you still cannot make Firefox your main browser, it's a good idea to contact Apple support about this.

See also: https://support.mozilla.org/en-US/questions/1347552

Hope I helped!

Kind regards,

Bithiah

Hữu ích?

more options

Make sure you install Firefox properly and that you do not launch Firefox from the DMG (Disk Image) file.

Open the Firefox Disk Image file and drag the Firefox application to the Applications folder on your hard drive. You shouldn't double-click the Firefox application to run it from the Disk Image, but instead drag it out of the DMG folder.

Hữu ích?

more options

Giải pháp được chọn

Hey there!

If your problem is solved, please mark a solution so that others can see this thread is solved. Thank you in advance!

Kind regards,

Bithiah

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.