Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Youtube videos lags at random times (didn't tried with other video platforms)

  • 10 trả lời
  • 3 gặp vấn đề này
  • 1823 lượt xem
  • Trả lời mới nhất được viết bởi Unnat

more options

I am on arch linux with firefox version 91.0 and I recently left firefox (i think at version 89) tried out some other browsers for a while but came back to it and now it was version 91.0 and now I am noticing some lags/frame rate degrade at random times and I didn't found a relevant solution any where

I also tried h264ify as I read about the video codec youtube uses but that didn't fixed it and also tried a solution on the forum that said to disable H264 plugin and enable h264ify but that didn't worked as well

Processor: Intel i3-4130 (4) @ 3.400GHz GPU: Intel 4th Generation Core Processor Family RAM: 4gb


here is some more information about my processor and gpu fetched from lspci:


00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06) Subsystem: Lenovo Device 367d Flags: bus master, fast devsel, latency 0 Capabilities: [e0] Vendor Specific Information: Len=0c Kernel driver in use: hsw_uncore


00:02.0 VGA compatible controller: Intel Corporation 4th Generation Core Processor Family Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller]) DeviceName: Onboard IGD Subsystem: Lenovo Device 367d Flags: bus master, fast devsel, latency 0, IRQ 28 Memory at f7800000 (64-bit, non-prefetchable) [size=4M] Memory at e0000000 (64-bit, prefetchable) [size=256M] I/O ports at f000 [size=64] Expansion ROM at 000c0000 [virtual] [disabled] [size=128K] Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit- Capabilities: [d0] Power Management version 2 Capabilities: [a4] PCI Advanced Features Kernel driver in use: i915 Kernel modules: i915


edit: fixed formatting a bit as it was causing horizontal scroll.

I am on arch linux with firefox version 91.0 and I recently left firefox (i think at version 89) tried out some other browsers for a while but came back to it and now it was version 91.0 and now I am noticing some lags/frame rate degrade at random times and I didn't found a relevant solution any where I also tried h264ify as I read about the video codec youtube uses but that didn't fixed it and also tried a solution on the forum that said to disable H264 plugin and enable h264ify but that didn't worked as well Processor: Intel i3-4130 (4) @ 3.400GHz GPU: Intel 4th Generation Core Processor Family RAM: 4gb here is some more information about my processor and gpu fetched from lspci: 00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06) Subsystem: Lenovo Device 367d Flags: bus master, fast devsel, latency 0 Capabilities: [e0] Vendor Specific Information: Len=0c <?> Kernel driver in use: hsw_uncore 00:02.0 VGA compatible controller: Intel Corporation 4th Generation Core Processor Family Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller]) DeviceName: Onboard IGD Subsystem: Lenovo Device 367d Flags: bus master, fast devsel, latency 0, IRQ 28 Memory at f7800000 (64-bit, non-prefetchable) [size=4M] Memory at e0000000 (64-bit, prefetchable) [size=256M] I/O ports at f000 [size=64] Expansion ROM at 000c0000 [virtual] [disabled] [size=128K] Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit- Capabilities: [d0] Power Management version 2 Capabilities: [a4] PCI Advanced Features Kernel driver in use: i915 Kernel modules: i915 edit: fixed formatting a bit as it was causing horizontal scroll.

Được chỉnh sửa bởi James vào

Giải pháp được chọn

I am now using Firefox Dev Edition and everything is fine no lags!

EDIT: I actually found that it did lagged after watching a couple of more videos but, I did found the solution: I just had to decrease the media.benchmark.vp9.threshold in about:config. My current value for this is, 152

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (10)

more options

Verify that you have the most recent ffmpegs and libav. see screenshot Because of the specs of the computer, it would be interesting to see the system load when playing videos.

Operating System: openSUSE Tumbleweed 20210817 KDE Plasma Version: 5.22.4 KDE Frameworks Version: 5.85.0 Qt Version: 5.15.2 Kernel Version: 5.13.8-1-default (64-bit) Graphics Platform: X11 Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

more options

Hey, sorry for late reply I have the latest version of ffmpeg and firefox on my system

and here are system load screenshots: 1st - Idol, firefox not running, 2nd - Firefox running but no video playing, 3rd - Firefox running and playing a 1080p 30fps video

more options

.....

Được chỉnh sửa bởi jonzn4SUSE vào

more options

I hopped on an old laptop that dual boots XP and openSUSE 42 and had no issue with this video at 720p. Can you provide a link to a video and the resolution used?

more options

It actually happens to me with every video (even 144p) here is the one being played when took the screenshot

and as I have mentioned that this didn't used to happen when I was on Firefox a few weeks ago.. and the version on your old laptop looks Pretty old, so, this may cause a big difference

Được chỉnh sửa bởi Unnat vào

more options

.....

Được chỉnh sửa bởi Unnat vào

more options

Try downloading a separate copy of Firefox and run it from the folder(do not sign into you Firefox account) to see what happens.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

more options

Downloaded firefox version 89.0 and executed the firefox executable in the folder and after that I played a couple of videos and there were no lags..

So I think this is a recent version problem

more options

You should get the same current version and download to a folder and run it.

more options

Giải pháp được chọn

I am now using Firefox Dev Edition and everything is fine no lags!

EDIT: I actually found that it did lagged after watching a couple of more videos but, I did found the solution: I just had to decrease the media.benchmark.vp9.threshold in about:config. My current value for this is, 152

Được chỉnh sửa bởi Unnat vào