Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox 91 http redirect not working

  • 14 trả lời
  • 2 gặp vấn đề này
  • 101 lượt xem
  • Trả lời mới nhất được viết bởi Chris Ilias

more options

As per the subject. Website www.bom.gov.au

Regards Ron Bugeja

Giải pháp được chọn

Hello all. Thankyou for your advice and suggestions.

After working through them without success I decided to save my current Profile and perform a Refresh. Opening in purely default Firefox, I was able to access www.bom.gov.au and all other websites.

I then restored my Profile only to have the issue return. I have now performed another Refresh and restored only my Bookmarks - problem solved. So there must have been some incompatibility in my previous data or settings.

Regards, Ron

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (14)

more options

Hello Ron! It's seems to me that www.bom.gov.au is working now. It was just a temporary redirection. Hope it's alright at your end.

Kind regards,

Bithiah Koshy

more options

Please explain the problem in detail. What happens? What is/are the exact error message(s) ?

Is the link you posted what you are using, or where you should end up? I used the link and went to www.bom.gov.au

more options

Hello FredMcD,

The link is for the Australian Bureau of Meteorology website. Since the upgrade to 91.0, going to the webpage www.bom.gov.au brings up a blank screen with the following message:

'The Bureau of Meteorology website does not currently support connections via HTTPS.

You will shortly be redirected to http://www.bom.gov.au.'

However, no redirection occurs. The message appears to automatically refresh every 10 seconds.

more options

This is what I get in Linux and Win11 with several versions of Firefox including ESR.

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem,

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

While you are in Troubleshoot(Safe) mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Thankyou for your responses.

I have tried all of FredMcD's suggestions, but still no progress.

I have no issues with other websites/urls.

more options

If I type www.bom.gov.au in the url bar, the site loads without an issue. Have you selected HTTPS-Only Mode in Settings (Privacy & Security page)?

more options

Are you using a bookmark, or entering the address manually?

more options

See also:


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

more options

Giải pháp được chọn

Hello all. Thankyou for your advice and suggestions.

After working through them without success I decided to save my current Profile and perform a Refresh. Opening in purely default Firefox, I was able to access www.bom.gov.au and all other websites.

I then restored my Profile only to have the issue return. I have now performed another Refresh and restored only my Bookmarks - problem solved. So there must have been some incompatibility in my previous data or settings.

Regards, Ron

more options

That was very good work. Well Done.

more options

Hi Ron - I have the same problem , and an actual functioning workaround for Win10 , Firefox Version 91.0.2 (64-bit) that should work for others until someone fixes it. In my local (Victorian) agricultural area, the weather radar is very important. . Basically , I leave HTTPS prefence - ON - but exempt the BOM site from HTTPS - this is a Kludge as you have to do it with every BOM page you want to see which is a pain, but it works for me and all I want to see is the radar , so hopefully it will work for you or at least lead you to a useful solution for now. . My "thread" is https://support.mozilla.org/en-US/questions/1349030 . But there are no real useful answers there yet , but I have put my "Kludge" on the problem - in the question anyway in the hopes it can actually be helpfull to someone. . I have reported it to BOM (who blame FireFox) and FireFox doesnt yet seem to understand the problem (it works with all else like Edge etc). . My guess is that in the initial page request FireFox "asks the availability of HTTPS - question" of the BOM site, no matter what the basic settings are - and then BOM's site just "see's" someone ask about HTTPS and throws you out. . Best of Luck

Được chỉnh sửa bởi ponytrekker vào

more options

Hi Ron , I tried your solution , but that didn’t work for me. . As I said , I am using a Kludge (not a fix) as it is a desperate workaround. . For whatever reason - it seems the latest version of Firefox that I am using may not actually save the exceptions on the HTTPS page anyway (even though it says it does) - as due to concerns over a large weather storm, I did a full system shutdown - and then later a system restart and the exceptions I had put in were all completely gone (so I had to use Edge to get into BOM this morning (3 Sept 2021) , to get the address of the radar page to redo the exception. . Now - FaceBook is having the exact same HTTPS problem at login on the “Facebook.com.au” site for me (3 Sept 2021) – so its not far away from happening on the “Facebook.com” site as they have jus rolled out yet another major update in the last few days – so I have had to add an exception to that site too . So the complaints may soon be coming in thick and fast for this if everyone’s got it.

more options

Given that this thread is already solved and more people might start using it for their own questions, I'm going to lock it.

For ponytrekker's issue, please use https://support.mozilla.org/en-US/questions/1349030