Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Google play store green install button doesn't work on firefox

  • 11 trả lời
  • 1 gặp vấn đề này
  • 151 lượt xem
  • Trả lời mới nhất được viết bởi FredMcD

more options

When I am on a google play store app page, the green download button doesn't work.

What happens: 1. Click the green button 2. The round google processing-icon appears on the page briefly 3. Nothing happens, page does not render a pop-up stating the app will be installed on my device

What I tried:

  • Turn off ublock: problem persits
  • Disable all add-ons: problem persits
  • A clean portable version: problem persits
  • Tried on a clean portable google chrome install: everything works (app get's installed)

Problem started 4 or 5 days ago...

I am running Firefox portable 64bit on windows 10. I can just install from the android playstore app, but I need it to work on my desktop like it has always worked.

I someone could help, I'd really appreciate this.


Tất cả các câu trả lời (11)

more options


"I someone could help, I'd really appreciate this."

Should be

If someone could help, I'd really appreciate this.

more options

We all make missteeks . . mistooks . . mischiefs . . . . . errors. Check out;


Great Writing, Simplified

Compose bold, clear, mistake-free writing with Grammarly’s AI-powered writing assistant.

ron_r said

When I am on a google play store app page, the green download button doesn't work.

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

Oh, I didn't realize you could install apps that way.

I think I got the full process when I tested with an app -- clicked the button in the overlay, confirmed by entering password -- but weirdly at the end, there is still an Install button on the web and the app is not actually on my phone.

Well, I don't know what's going on, sorry.

more options

@FredMcD Tried the trouble shooting mode, but still the same problem. I did try in an fully separate portable clean install and still the problem persisted, this means the cache and cookies are clean because I am starting from a clean separate portable install. Chrome works, but firefox doesn't seem to work.

The actual firefox I work on is also a portable version, this means the 2 versions I tried (my current portable installation and the second test portable installation) are completely separate.

I could have overlooked something, but this is just weird because the portable versions are completely segregated from each other and the OS. (portable apps version).

Almost all my apps are portable apps the only thing that is installed: - GhostVolt - ShadowDefender - Starmenu X

I have been running ghostvolt for about a month, and ShadowDefender almost 11 years, startmenu X for about a year.

Everything else is portable, as I like to run a clean ship on my OS.

This issue started about 5 days ago. It's easy to put the blame on firefox but in this situation I absolutely have no clue what could be wrong from my end.

@jscher2000 If you are logged into the same account in google play in firefox (any browser) as in your smartphone, then installing an app from the browser is like passing on an instruction to the device ordering it install that app. If you have multiple devices with that account, the play store website asks on which device you want to install the app on.

It always worked and I have scripted a way to install apps on multiple accounts this way (but this is beyond the scope of this issue, just wanted to state the reason why I need this to work).

In any case, thank you for the feedback. I really appreciate it.

more options

ron_r said

The actual firefox I work on is also a portable version

Firefox Portable is a 3rd-party build. Support is available here: http://portableapps.com/forums/support/firefox_portable

more options

I just tried the official firefox, meaning install firefox through the official installer, but the problem still persists.

more options

Delete browsing, search and download history on Firefox {web link}

Remove a single website from your history {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings And Passwords.

more options

@FredMcD Do I need to do those steps in a clean install? (Tried a clean install on another pc and the problem still persisted). I tried an older version 78.02 and there it works everything above that persists the issue. EDIT: submitted a bug report in bugzilla

Được chỉnh sửa bởi ron_r vào

more options

When just uninstalling a program, some data might be left behind and could cause problems with the new install. By removing the folder instead, everything gets taken out. Especially any corrupt files.

ron_r said

Tried a clean install on another pc and the problem still persisted).

Then the clean install might not work. But please try anyway.

I tried an older version 78.02 and there it works everything above that persists the issue.

If nothing works, we can try to re-install the older program.

submitted a bug report in bugzilla

Well done. Can you post the link to it, please?

more options

The link to the issue in bugzilla: https://bugzilla.mozilla.org/show_bug.cgi?id=1722687

more options

Hopefully, they can do something.