Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Showing only a's or e's on websites

  • 7 trả lời
  • 3 gặp vấn đề này
  • 71 lượt xem
  • Trả lời mới nhất được viết bởi viko.dichev

more options

Recently a problem appeared in certain websites (Wikipedia for example) since I updated Firefox. It would only show me a's or e's. See attached image. I have already tried to refresh Firefox, turning off extensions and themes, but to no avail. There is no such problem with Google Chrome. I have shared configuration info. Thank you for the help!

Đính kèm ảnh chụp màn hình

Được chỉnh sửa bởi viko.dichev vào

Giải pháp được chọn

You can try to disable WebRender by setting gfx.webrender.force-disabled = true on the about:config page.

What font is Firefox using ?

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (7)

more options

Wow, that is really weird.

Wikipedia does not specify a font by name, it simply uses the font you have defined as your default sans-serif font. I wonder whether Firefox is having a new problem with whatever font that is on your distro? You could experiment with selecting a different Sans font on the Settings/Preferences page. Use the "Advanced" button to open the Fonts dialog. (See screenshot from Windows, your defaults are almost certainly different.)

Hữu ích?

more options

Thank you for the fast and detailed answer.

I just tried a couple of options for sans-serif and unfortunately none of them worked. I'll keep trying different things.

Hữu ích?

more options

Hopefully someone more familiar with Linux can join in because it could be some unique (in)compatibility issue.

Hữu ích?

more options

Giải pháp được chọn

You can try to disable WebRender by setting gfx.webrender.force-disabled = true on the about:config page.

What font is Firefox using ?

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Hữu ích?

more options

Wow, thanks a lot! After a long battle, I finally figured it out. Thank you all for helping me!

Hữu ích?

more options

What in particular fixed your issue, as this can help others ?

Hữu ích?

more options

It turns out that I had a weird corrupt DejaVu Sans font installed which was overriding the default one. I found out via the Inspector tab that this was what I was using and then located the font using the font browser. Unsurprisingly, it had only 'a's defined.

The first solution I found was to use another default font like FreeSans, but eventually found out how to remove the systemically installed font.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.