Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Latest version adds extra space bookmarks and adds weather to task bar

  • 20 trả lời
  • 2 gặp vấn đề này
  • 147 lượt xem
  • Trả lời mới nhất được viết bởi Chris Ilias

more options

The latest version adds space between bookmarks making my Bookmark Toolbar overflow down the right side way too large. Is there someway to make Bookmarks space like before?

I now have a weather report on my often overcrowded task bar. How do i make it go away?

Jay

Giải pháp được chọn

This wider menu item spacing is a feature of the Firefox 89 "Proton" redesign. I can give you a quick short-term workaround, but a more durable solution will require more work.

Temporary Fix -- Firefox 89-90 ONLY

For testing purposes, there is a preference to switch between new style and old style menus. It helps with the spacing, but might be a tad bit glitchy:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste browser.proton.contextmenus.enabled and pause while the list is filtered

(3) Double-click the preference to switch between true (new style) and false (old style)

In my test, the Bookmarks menu on the optional top Menu Bar was messed up in the existing window, but looked okay in a new window. The effect is not as significant on bookmarks or history for some reason.

Longer Term Community Workaround

This involves setting up a userChrome.css file. The full instructions are in the following thread: https://support.mozilla.org/questions/1337841

I'm sure we'll refine that during the course of the month so when the temporary preference is removed, it will be airtight.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (20)

more options

Hi Jay, there's no built-in way to adjust the amount of space between bookmarks on the Bookmarks Toolbar. I think you would need to use a community supported workaround of creating a userChrome.css with style rules to tighten up the spacing. I'll try to look into it if no one jumps in with more information on that.

Regarding weather on your Windows Taskbar, Firefox can't take credit. Check out this other thread: https://support.mozilla.org/questions/1340097

more options

Thanks I should have guessed Windows created the weather icon in my task bar instead of Firefox!

The spacing between items in menus has changed as well as the bookmark. It's only annoying to me with the bookmarks.

thanks, Jay

more options

Giải pháp được chọn

This wider menu item spacing is a feature of the Firefox 89 "Proton" redesign. I can give you a quick short-term workaround, but a more durable solution will require more work.

Temporary Fix -- Firefox 89-90 ONLY

For testing purposes, there is a preference to switch between new style and old style menus. It helps with the spacing, but might be a tad bit glitchy:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste browser.proton.contextmenus.enabled and pause while the list is filtered

(3) Double-click the preference to switch between true (new style) and false (old style)

In my test, the Bookmarks menu on the optional top Menu Bar was messed up in the existing window, but looked okay in a new window. The effect is not as significant on bookmarks or history for some reason.

Longer Term Community Workaround

This involves setting up a userChrome.css file. The full instructions are in the following thread: https://support.mozilla.org/questions/1337841

I'm sure we'll refine that during the course of the month so when the temporary preference is removed, it will be airtight.

Được chỉnh sửa bởi jscher2000 vào

more options

I tried the " about:config" "browser.proton.contextmenus.enabled" solution. It had no effect for me.

Dropdown Bookmarks menu still way too "puffy"

I'm on Ubuntu 18.04.5, 64 bit, Firefox 89.0.1 (64-bit).

EDIT - The dropdown from the top right "underlined star" icon is the one with excessive space. If I do "Alt - Bookmarks" spacing is good.

Được chỉnh sửa bởi RogerDavis vào

more options

Perhaps you will need to try the userChrome.css option to squeeze them closer together.

more options

Thanks both the temp fix and the userChrome.css worked for me in W10Pro.

Jay

more options

Re: "This wider menu item spacing is a feature of the Firefox 89 "Proton" redesign. I can give you a quick short-term workaround, but a more durable solution will require more work.

Temporary Fix "

Does not work anymore in version 91 !!

more options

frfx said

"Temporary Fix " Does not work anymore in version 91 !!

Correct, that was for Firefox 89-90 only.

I had not noticed that Firefox 91 released today. I may need to update some threads...

more options

Thank you for your support, really appreciated; hope you find another easy workaround for this issue for version 91 & up..

more options

Can they not keep something as it is getting worse and worse this way ..... way to much spacing now in between bookmarks !!! ridicules .. What was wrong with the older stile? First we have to color the maps our self with a Userchrome thing now we have this ... Not all are computer wizz ........ I used to enjoy FireFox but it getting as bad as edge and chrome...

more options

If firefox doesn't fix this doublspacing in bookmarks someone out there may have to make a browser that people can use on there desktop without having all this wasted space. Now my bookmarks goes past the bootom of the screen now, and yes I do use folders as well and still it goes past the bottom.

Please mozilla fix problem, allow single of double space options

more options

ABSOLUTELY HORRIBLE situation these double-spaced bookmarks. It is so frustrating that software all around the block are imposing horrendous changes on all that are either not required or only of interest to a subset. I bet the programmers don't work with their code double-spaced... though perhaps they were not in charge of this decision. I've tried every suggestion for reducing the spacing in the Bookmarks menu dropdowns with no effect. 92.0b3 (32-bit). PLEASE LET US CONTROL OUR SPACING - a computer with a mouse and 1280x1024 screen is quite simply NOT the same as a touchscreen or some very high res screen !!!! Aside from such things Firefox is otherwise a formidable product and it's awful to hate using it because of decisions being made like this! David

Được chỉnh sửa bởi miscellaneous47 vào

more options

F ... I... X... T... H... E... B... O... O... K... M... A... R... K... S... P... A... C... I... N... G... N... O... W  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !  !

Được chỉnh sửa bởi RogerDavis vào

more options

Please find an easy solution to this double spacing fiasco for us illiterate non-programmers.

more options

GET YOUR THUMBS OUT OF YOUR UPLOAD PORTS AND LISTEN TO THE USERS !!! >FIX< THIS PROBLEM !!!

more options

OK, I got the fix for the bookmark spacing a week or so ago, and THANKS! But now FF is pushing v. 91 and jscher2000 says the fix won't hold up for v.91. So what am I risking by refusing to accept v. 91? I would quit Firefox rather than slog through that long bookmark list. I can't believe they don't build in an option to keep it single-spaced.

Được chỉnh sửa bởi StandingO vào

more options

ARE YOU LISTENING ?!?

more options

Hi RogerDavis, shouting at support forum volunteers isn't going to change things. There are requests on file in the relevant places about this and a later version is expected to have more tightly spaced menus in the optional Compact mode. That options is in testing in Firefox Nightly (alpha test version of future Firefox 93) but we don't have details on whether it will be in Firefox 92.

Until then, you could consider:

Unofficial Community-Supported Workaround

Firefox users can modify the user interface of the browser using custom style rules. This involves setting up a userChrome.css file. If this is your first time, make sure to set aside 10 quiet minutes to work through it.

(For anyone who already has a userChrome.css file set up, you just need to add the rule under (A) to your file.)

(A) Select and copy the following style rule code

/*** Tighten up drop-down/context/popup menu spacing ***/

menupopup > menuitem, menupopup > menu {
  padding-block: 4px !important;
}
:root {
  --arrowpanel-menuitem-padding: 4px 8px !important;
}


(B) Generate and download a userChrome.css file

Open the following page and paste the above rules into the editor, replacing the sample rule:

https://www.userchrome.org/download-userchrome-css.html

Some users will want to modify the code at this point because they want even tighter spacing. The first attached screenshot shows the changes when you keep 4px or use 3px or 2px. (The 8px refers to the left side and right side, so no need to change that part.)

Once your code is ready, click "Generate CSS File" and save the userChrome.css file to your computer. (See second attached screenshot)

Use the downloads list on the toolbar to open the downloads folder directly to the new userChrome.css file. (See third attached screenshot)

Minimize that file browser window for later reference.

(C) Create a new chrome folder in your profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)

https://www.userchrome.org/how-create-userchrome-css.html

I have videos for both Windows and Mac in case the text is not clear.

(D) Move the userChrome.css file you generated in Step B into the chrome folder you created in Step C

(E) Set Firefox to look for userChrome.css at startup -- see step #6 in the above article.

The next time you exit Firefox and start it up again, it should discover that file and apply the rules.

Success?

I suggest bookmarking any thread you get userChrome.css code from for future reference (in case the rule stops working).

more options

Thanks for info on the future plans ! Without this information, frustration sets in.

We all now know that something is in the works, and we are not being ignored !!!

I know it may be difficult to project time frames, but even a wild guesstimate would be appreciated, and add to the cooling effect.

Thanks !!!

more options

Hi everyone, jscher2000's post was marked as the solution by the person who asked the original question (Jay). Your issue may have similar symptoms, but it is likely a different cause/solution. For better help, it would be best to use https://support.mozilla.org/en-US/questions/new where volunteers can get more details about your setup.

Because this thread is solved and more people might start using it for their own questions, I'm going to lock it.