Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox not running scripts for longer than 30 seconds after update

  • 11 trả lời
  • 1 gặp vấn đề này
  • 30 lượt xem
  • Trả lời mới nhất được viết bởi tony185

more options

Hi, hoping someone can help point me in the right direction....I have a web app that has lots of data, we run several scripts that can take a while to process. All was operating fine on version FF87, version 88 would just stop processing the script and the browser would not allow me to do anything else on that site. ... there were no error messages (that I can find).

I downloaded the Beta of V89 and all worked fine Public release of V89 has the error It works fine on all other browsers It works fine on the local server version on my machine

site is php7.2 ...

...any information would be helpful to me.. please and thank you in advance!!

Tất cả các câu trả lời (11)

more options

Please provide a public link (no password) that we can check out. No Personal Information Please !

Hữu ích?

more options

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Hữu ích?

more options

You don't get a notification that the page is running slowly, either in an info bar or in a popup alert? Hmm, have you modified the dom.max_script_run_time preference in about:config to allow scripts to become non-responsive for longer than 10 seconds without a warning? If so, try restoring the default value of 10 or increase it to no more than 20 (as suggested in Warning Unresponsive script - What it means and how to fix it).

If that's not relevant/helpful:

If you open the Web Console before the trouble starts, are there any relevant-looking error messages in there? More info on that tool: https://developer.mozilla.org/docs/Tools/Web_Console

Hữu ích?

more options

Thanks for your input/feedback

OK, so upon further testing, one of the requests continues to process in the background, the browser is useless on the site until it completes. The Animated dot indicating something is happening stops at 30 secs, but 10mins later when it is complete I can refresh and see the result.

I have edited dom.max_script_run_time making no difference

below are the headers in case there is some info in there that helps? (???????? represents the domain name)

POST https://?????????????????/generate_word_packinglist.php Transferred0 B (0 B size) Referrer Policy strict-origin-when-cross-origin


Accept text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 Accept-Encoding gzip, deflate, br Accept-Language en-US,en;q=0.5 Alt-Used ????????????????? Connection keep-alive Content-Length 106 Content-Type application/x-www-form-urlencoded Cookie _ga=????????????; _gid=?????????????????; sec_session_id=c8b6a73fb6732a8740a5b697d3ed8fc8 Host ????????????????? Origin https://????????????????? Referer https://?????????????????/packinglist.php?sd=1623678800&day=6 TE Trailers Upgrade-Insecure-Requests 1 User-Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:88.0) Gecko/20100101 Firefox/88.0

Hữu ích?

more options

I think those are the request headers. Is there any response?

Hữu ích?

more options

jscher2000 said

I think those are the request headers. Is there any response?

it says 'No response data available for this request'

Hữu ích?

more options

You know I missed the part about 10 minutes. Does the site use a service workers to receive new content in the background? Sites that have registered a service worker thread should appear on the about:serviceworkers page. I don't know how you can see the status of something that is in process via a service worker.

Hữu ích?

more options

jscher2000 said

You know I missed the part about 10 minutes. Does the site use a service workers to receive new content in the background? Sites that have registered a service worker thread should appear on the about:serviceworkers page. I don't know how you can see the status of something that is in process via a service worker.

no it does not....

Hữu ích?

more options

@jscher I have done some testing ....created a page that illustrates my issue [sent link as PM] and found that if the script returns nothing at all in the first 30 secs or so it just stops this is not an issue with before FF88 this is not an issue with other browsers

Another finding is that only happens when using https [sent link as PM] http persists until complete

Hữu ích?

more options

Thanks for the example. On your page, the throbber never stops rotating, so it's hard to tell what Firefox is up to. I'm not sure what is happening.

For reasons I don't remember I have a test page that uses

<?php 
sleep(120);
?>
 

To create a two-minute delay in sending the page. These results also vary by protocol:

If you have a lot of bandwidth and patience, you can isolate the patch that caused the change using a tool called Mozregression:

https://mozilla.github.io/mozregression/

Hữu ích?

more options

@jscher thanks for your feedback.... I modified your sleep code to sleep based on the querystring value

using https it works for 29 seconds and times out without error message at 30secs http works perfectly for every value I entered

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.