Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox not taking input from userChrome.css

  • 4 trả lời
  • 1 gặp vấn đề này
  • 8 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

My tab bar is way, way too small on Linux. I followed Arch's own documentation on how to fix this by increasing `layout.css.devPixelsPerPx` (mine is at 1.4), and then adjusting font size by editing userChrome.css to select the desired size. Problem is that Firefox won't actually change anything based on what I put in that file. I have set `toolkit.legacyUserProfileCustomizations.stylesheets` to True, and I have attached a photo of my userChrome.css (yes, I'm using nano because Vim is too advanced for my smooth brain). I changed it to a ton of different values and I can confirm that the font size is not actually changing.

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Ha ! I missed in your screenshot that you were using https:// for the @namespace line. This should be http:// to make this work.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */
Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (4)

more options

The tabbrowser-tabs container has an id and not a class name: #tabbrowser-tabs An individual tab has a class name that can be used as a selector: .tabbrowser-tab

So you can use either one of these (72px would blow the tabs, so make sure to reduce that value):

/* font size for all tab */
#tabbrowser-tabs {
 font-size: 15pt !important;
}

/* font size for an individual tab */
.tabbrowser-tab {
 font-size: 15pt !important;
}

Hữu ích?

more options

Thanks for the response. Unfortunately this still doesn't work. 72px was a test value to confirm that nothing was actually changing, the value I am actually trying to use is 15px so I changed that

Hữu ích?

more options

Fixed it - the "@namespace url" line at the top of the file was causing it to not work, so if you run into this question in the future with the same problem as me, delete that line.

Hữu ích?

more options

Giải pháp được chọn

Ha ! I missed in your screenshot that you were using https:// for the @namespace line. This should be http:// to make this work.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.