Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox opening in the background on its own, on startup and consuming high amount of CPU

  • 4 trả lời
  • 2 gặp vấn đề này
  • 8 lượt xem
  • Trả lời mới nhất được viết bởi jscher2000

more options

Every time I switch on my laptop, I found that it was heating up without opening anything. I open the task manager and I see that Firefox is running and using a huge amount of the CPU and apparently consuming a lot of the battery as well. Firefox is not there in my startup list. I have reinstalled and installed multiple times. I have tried changing toolkit.winRegisterApplicationRestart to false. I have tried changing browser.tabs.remote.autostart to false.

If I do open Firefox now, without ending the task that is already running, and then close it later, it is still running in the background. Only way to stop this task running is to end task and I have to do it every time I switch on my Laptop.

I hope I have described the problem well, please let me know what other details I can provide. I am putting a screenshot of the task running as well. Thanks in advance

Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (4)

more options

The behavior sounds like what a malware would do. Run a malware scan and see if it picks up anything suspicious.

Someone else had a similar problem to you. You can see the resolved thread here: https://support.mozilla.org/en-US/questions/1291454

Hữu ích?

more options

Did you end up finding a solution? I have this exact issue.

Hữu ích?

more options

Firefox will not start on its own. However, if something tries to access the web, it will do so thru your default browser.


Create a shortcut on your desktop for this Windows command; TASKKILL /T /F /IM Firefox.exe


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

Starting Any Computer In Safe Mode (web link) Free Online Encyclopedia

https://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/

https://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10/ +++++++++++++++++++++++++++++++++++++++++++++++ If the problem goes away with the computer in Safe Mode, the problem is with one of the other programs on the system.

Hữu ích?

more options

Hi Zabinga, are you on Windows 8, 8.1, or 10?

If you open the Task Manager, show the full list, then switch to the Details tab, you can right-click any column heading and add a new column called Command Line. This will show you where the mystery Firefox is starting from, and any command-line parameters that might be causing it to run hidden (such as "headless") and any URL it is auto-loading.

That might be useful in tracking down the source of the problem, such as coin mining malware.

Actually, the link earlier in this thread to https://support.mozilla.org/questions/1291454 covers this same suggestion.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.