Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

firefox url bar

  • 9 trả lời
  • 1 gặp vấn đề này
  • Trả lời mới nhất được viết bởi jscher2000

more options

How the flipping f can I disable this (see attached image). I was able to do this previously with setting "browser.urlbar.update2 = false" Now it doesn't work anymore.

I use keyword for search engines extensively and this is very very annoying!

How do I make it go away.

I use Firefox 87.0 (64-bit) on Mac os x Catalina 10.15.6

Thanks

Đính kèm ảnh chụp màn hình

Được chỉnh sửa bởi l0cus101 vào

Tất cả các câu trả lời (9)

more options

hello io,

have you tried fiddling with the settings?

you can copy the below url, then paste and go to here:

about:preferences#search

then if you go to the section called Search Shortcuts, you can remove some of them.

Hữu ích?

more options

Hi databaseben, Thank you for your input. Like I said, I do use the search keywords extensively, so I most definitely do not want to remove any of them!

I just want the old behavior back and not... whatever this is.

Thanks

Hữu ích?

more options

l0cus101 said

Hi databaseben, Thank you for your input. Like I said, I do use the search keywords extensively, so I most definitely do not want to remove any of them! I just want the old behavior back and not... whatever this is. Thanks

I agree, Mozilla have made the url bar in my opinion noisy. Even though I have unchecked all the other search options in the settings and have only Google checked, they keep pulling from bookmarks, history, and open tabs. You have to bring back the search bar in toolbar to get back to the "old behavior".

Hữu ích?

more options

I dont know?

I use to get Amazon, bookmarks, tabs and history.

But now when I click on the URL bar and do a search like for plants, i get a plain listing of google search possibilities.

The settings seem to work on my end but not sure why not for you?

Hữu ích?

more options

I don't think there is a way to prevent this:

  • type the keyword
  • type a space
  • Firefox detects the keyword, removes it, and shows the selected search engine box

It is freakishly large in your screenshot; mine just says "Wikipedia (en)". Maybe it's a regional difference.

I'm sure there is a way to hide the blue box with custom style rules in a userChrome.css file. That won't change the behavior, but would be less of an eyesore. I haven't noticed rules having been posted for that.

Hữu ích?

more options

Thanks everyone! For now I'm downgrading to FF 86.0.1

@jscher2000 It is not just that it is visually dumb, it also affects the way keyword search works. For example I could type the keyword "wke" for doing a wikipedia search from the url bar. If I type "wke" and do enter (without a search query) it would take me directly to the wikipedia main page. I think with the recent auto update to FF 87 mozilla disabled the "browser.urlbar.update2 = false" It was possible, but I don't think it is now anymore.

@databaseben I don't think I am communicating my issue correctly to you. But thank you for your effort.

Hữu ích?

more options

any time!

btw, why downgrade?

i have both V86 & V87 installed on same desktop.

but as an assurance, export your v87 bookmarks & Pw's before you unistall

Hữu ích?

more options

I'm not seeing a label as long as in your screenshot (Wikipedia (en)).

Note that you can initiate a search via '@' in current releases.

Hữu ích?

more options

l0cus101 said

It is not just that it is visually dumb, it also affects the way keyword search works. For example I could type the keyword "wke" for doing a wikipedia search from the url bar. If I type "wke" and do enter (without a search query) it would take me directly to the wikipedia main page. I think with the recent auto update to FF 87 mozilla disabled the "browser.urlbar.update2 = false" It was possible, but I don't think it is now anymore.

Yes, the temporary preference available while the bugs were worked out is gone because the design introduced in Firefox 83 is now final.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.