Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefoxes own pop ups

  • 10 trả lời
  • 1 gặp vấn đề này
  • 9 lượt xem
  • Trả lời mới nhất được viết bởi phil.nicol

more options

how do I stop a Firefox popup requesting to install a Firefox extension?

Giải pháp được chọn

It is about this content.

<div class="offers" id="offers">    <div class="extension-browser extension-browser__firefox"> 

You can add code to the userContent.css file.


@-moz-document domain(www.rt.com){
/* hide offers */
 #offers { display:none!important; }
/* hide firefox extension */
 .extension-browser__firefox { display:none!important; }
}

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (10)

more options

Can you show a screenshot of this popup?

Hữu ích?

more options

Thank you for your quick response.

This is not a serious technical issue but only a matter of my convenience; but I don't like this offer to install the extension coming up so regularly, so it's more of an visual nuisance.

I hope you don't find this question a bother and waste of your time; in the grand scheme of things this is a small issue so I appreciate your effort.

Thanks

Hữu ích?

more options

It doesn't look like our popup.

Được chỉnh sửa bởi TyDraniu vào

Hữu ích?

more options

Doesn't look like. Or isn't?? It's got your name on it, who would be doing that?

Hữu ích?

more options

I also us RT and that's from them wanting you to install their extension. I use Adblock Plus to block that element. Check to see if whatever ad-blocker you're running has something that can block the elements. see screenshot

Hữu ích?

more options

I've just been trying uBlock Origin and blocking any pop ups also blocks opening another tab off of that site so it's obstructive. I was looking for a work around.

Hữu ích?

more options

To Ty

sorry, don't worry about it.

Hữu ích?

more options

Giải pháp được chọn

It is about this content.

<div class="offers" id="offers">    <div class="extension-browser extension-browser__firefox"> 

You can add code to the userContent.css file.


@-moz-document domain(www.rt.com){
/* hide offers */
 #offers { display:none!important; }
/* hide firefox extension */
 .extension-browser__firefox { display:none!important; }
}

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

Hữu ích?

more options

cor-el

Thank you. I'll try that. It's new territory for me but it looks appropriate. Live and learn.

Hữu ích?

more options

Thanks again, this solution is working well.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.