Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Google Earth won't load in browser; constisently stuck on loading screen

  • 11 trả lời
  • 1 gặp vấn đề này
  • 19 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

Hello all. For the past couple months i've been able to use the web version of Google Earth within the browser with little to no issue. However, about a week or two ago I discovered Google Earth stopped working whenever I tried to use it. I would navigate to Google Earth's website, click "Launch Google Earth", and be met with this loading screen which never changes. I went to Google for help and they had me run Memtest86 on my computer, to which I found all of my RAM sticks were fully functional with 0 error or issue.

I am using the absolute latest version of firefox as well as my operating system. I am running Windows 10 on a custom built PC for gaming, 64-bit. I've tried the following:

-disabling browser addons -restarting firefox -disabling my antivirus -disabling my antimalware -restarting computer (multiple times) -disabling ALL of my browser addons

Now at first google earth wouldn't load in google chrome either, but at some point during my troubleshooting for fixing google earth on firefox, google earth began loading in chrome with no issue. As of now the only browser that can't pull up google earth is Firefox. I've attached a screenshot of the error messages I see when loading Google Earth in firefox.

Please, any and all help would be greatly appreciated. If there's anymore relevant, useful information I could provide then please let me know.

Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (11)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Hữu ích?

more options

Thank you for your response. To my knowledge I am not blocking any content.

I restarted firefox in safe mode and proceeded to google earth. Google earth still won't load, however now there's a disclaimer saying it no longer can be loaded.

I have deleted the cookies and site data for the google earth website.

Even after doing all the above, the problem remains.

Hữu ích?

more options

See if these links help. https://www.bing.com/search?q=webgl

Hữu ích?

more options

This link takes me to a Bing search for WebGl. I opened get.webgl.org and see the spinning cube. I do not see any links.

Hữu ích?

more options

Sorry, current forum security sometimes delays the posting of messages. And in turn, we are not notified of those posts.


Your browser supports WebGL You should see a spinning cube.

Hữu ích?

more options

Those two statements are true. Okay, do you have any idea why Firefox won't load Google Earth?

Hữu ích?

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Hữu ích?

more options

Okay, so you've already said that and have posted those links. I already responded to those links and posted what I found.

Hữu ích?

more options

Oops, sorry.

I called for more help.

Hữu ích?

more options

No worries. At this point i'm ready to just uninstall firefox in its entirety; this isn't the only problem i'm having on Firefox and besides you nobody seems willing to help.

Hữu ích?

more options

You can check the Graphics section on the "Help -> Troubleshooting Information" (about:support) page for WebGL related messages.

You can possibly try to force WebGL by setting webgl.force-enabled = true on the about:config page.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.