Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Flag emojis not shown anymore in Firefox for Windows

  • 9 trả lời
  • 1 gặp vấn đề này
  • 31 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I know that flag emojis are basically not rendered on Windows platforms. A two-letter-combination is shown instead (e.g. DE for Germany), which is a known issue. Since a few months however, Firefox started to show flag emojis. I assumed that Firefox itself did show the flag emoji independently from Windows (as opposed to Chrome, which never did show flag emojis on Windows). Since a few days however, Firefox stopped showing flag emojis and shows the two-letter-combination again.

Why does Firefox not show flag emojis anymore?

Firefox 86.0 (32-Bit) Windows 10.0.19041 Home (64-Bit)

Tất cả các câu trả lời (9)

more options

I think that Firefox should be able to display flag emoji on Windows and may use the Segoe UI Emoji font.

  • about:config => font.name-list.emoji = WIN: "Segoe UI Emoji, Twemoji Mozilla"

Twemoji Mozilla is a font that comes with Firefox that can be used as fallback.

You can check in the Inspector what font is being used.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Được chỉnh sửa bởi cor-el vào

Hữu ích?

more options

Hi Hans, I run Windows 10 and I see that issue on the list here:

https://emojipedia.org/flags/

The page specifies each "letter" of the country code separately, and I guess the browser is responsible for combining them?

After searching around for a while, it seems the Windows Segoe UI Emoji font does not support country flags for reasons that don't seem to be well explained. If yours was working for a while, it is possible that an add-on was detecting and substituting them somehow?

Hữu ích?

more options

You can try to edit font.name-list.emoji and remove the first part leaving only "Twemoji Mozilla" (without quotes).

  • font.name-list.emoji = "Twemoji Mozilla"

Được chỉnh sửa bởi cor-el vào

Hữu ích?

more options

Hmm, that didn't make any difference for me in a quick try. Perhaps there is some preference for the OS font that lurks elsewhere.

Hữu ích?

more options

You can try to set gfx.bundled-fonts.activate = 1

Note that you need to close and restart Firefox to apply the change (pref is read at startup).


0     disable use of app-bundled fonts
> 0   enable use of app-bundled fonts
< 0   default (auto): decide at startup, based on the system environment

Được chỉnh sửa bởi cor-el vào

Hữu ích?

more options

Success! That change --

double-click gfx.bundled-fonts.activate and edit the value from -1 to 1

-- and then restarting Firefox, allows the flags to display.

Hữu ích?

more options

Thanks for your answers and suggestions! Modifying the setting "gfx.bundled-fonts.activate" from -1 to 1 on "about:config" did show flag emojis again on the page:

https://emojipedia.org/flags/

On my own web application they still did not show:

https://reiseberichte.reisen/themen/reiseberichte/reiseberichte.htm

By test however, I managed to show them on that page, if I explicitely add "Twemoji Mozilla" to the CSS style "font-family" for the corresponding tag.

I also have a YouTube channel, where I use flag emojis in video title/description. There, they are not shown as well. Obviously YouTube does not have "Twemoji Mozilla" contained in his styles, whereas "Emojipedia" does.

So, I conclude, Firefox on Windows does (currently) only show flag emojis, if the font "Twemoji Mozilla" is applied and if "gfx.bundled-fonts.activate" is set to 1. These two conditions were not necessary (at least not by explicite configuration) for Firefox on Windows during some months ago. Unfortunately not satisfactory these flag emoji issues on Windows (for Firefox and Chrome as well)...

Hữu ích?

more options

Thanks for your suggestions! Modifying setting "gfx.bundled-fonts.activate" from -1 to 1 on "about:config" did show flag emojis again on the page:

https://emojipedia.org/flags/

On my own web application they still did not show. By test however, I managed to show them on that page, if I explicitely add "Twemoji Mozilla" to the CSS style "font-family" for the corresponding tag.

I also have a YouTube channel, where I use flag emojis in video title/description. There, they are not shown as well. Obviously YouTube does not have "Twemoji Mozilla" contained in his styles, whereas "Emojipedia" does.

So, I conclude, Firefox on Windows does (currently) only show flag emojis, if the font "Twemoji Mozilla" is applied and if "gfx.bundled-fonts.activate" is set to 1. These two conditions were not necessary (at least not by explicite configuration) for Firefox on Windows during some months ago. Unfortunately not satisfactory these flag emoji issues on Windows (for Firefox and Chrome as well)...

Hữu ích?

more options

You will probably have to wait for Microsoft to update their Segoe UI Emoji font and add the flag symbols. In Firefox you can probably fix this with code in userContent.css.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.