Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Compatibility change

  • 24 trả lời
  • 1 gặp vấn đề này
  • 67 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

My Firefox browser seems to have reset itself to Windows 8 compatibility. I have Windows 10, 64-bit. Firefox will not open full screen, but opens a tiny, narrow window at the bottom of the screen which I have to use task manager to close. I remember one of the automatic updates coming through a few days ago.

Can I do anything other than uninstalling and a new install? I'd like to keep my favorites list, etc. I am at the extent of my computer skills with this.

Tất cả các câu trả lời (20)

more options

I should have added the following info from Properties:

The program listed in the control panel reads "Version: Mozilla Firefox 85.0.1 (x64 en-US)"

"Date modified 10/14/2017" Wrong. This is around the date I bought this computer. The program was updated many times since.

Trying to change compatibility shows "No previous versions"

In the section that instructs -"Run program in compatibility mode for:" the pull-down area of choices is greyed out. The top space has "Windows 8" written in and the menu is unworkable.

It seems that every change since the original installation has been wiped away.

Hữu ích?

more options

fzharris said

In the section that instructs -"Run program in compatibility mode for:" the pull-down area of choices is greyed out. The top space has "Windows 8" written in and the menu is unworkable.

Hmm, is the box unchecked? If the box is unchecked, then Windows 10 should run Firefox in Windows 10 mode and not in backwards compatibility mode:

fzharris said

Firefox will not open full screen, but opens a tiny, narrow window at the bottom of the screen which I have to use task manager to close.

Is this an actual Firefox window, or is it a little thumbnail? If it's an actual Firefox window, if you can activate it (click its title bar), try maximizing it using the window control menu:

Alt+Spacebar > Maximize

Does that work?

If so:

Unfortunately, that doesn't resolve the issue of the window being a dysfunctional size when it's not maximized, but if necessary, you could now delete a Firefox settings file that stores window dimensions and positions so Firefox goes back to default size and position. Here's how:

From inside your maximized Firefox window, open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then in the File Explorer window, right-click > Rename xulstore.json to something like xulstoreOLD.json.

Start Firefox back up again. Do windows display normally again?

That mini-reset may hide the menu bar and bookmarks toolbar. You can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

To turn on the Bookmarks Toolbar or Menu Bar, click it on the list.

Hữu ích?

more options

Thank you for responding.

The box in the compatibility mode is unchecked.

What opens at the bottom of the screen is a thumbnail, looking the same as the shortcut icon I keep on the desktop. When I put the mouse pointer on that, a tiny picture opens above it. The picture is about the same height as the icon, but about half its width. It's not possible to read what is in it, but it looks like the left side and right side of a screen mashed together.

Clicking on the part of the title that is there, closes the picture, but the thumbnail remains. The alt + spacebar also makes the picture disappear, but does nothing else. Clicking on the X on the upper right of the picture does not close it, nor does opening a menu and clicking close. At that point, I use the Task Manager and end the program. Then the thumbnail/icon goes away.

Hữu ích?

more options

Hi, could you right-click directly on the thumbnail to call up its window control menu and try Maximize there. Any luck?

Hữu ích?

more options

Maximize isn't shown as an option.

The menu lists: Open New Tab, Open New Window, New Private Window, Firefox, Pin to Taskbar, and Close Window.

Hữu ích?

more options

Oh, I meant to right-click on the thumbnail image of the open window (which seems to be off-screen).

Hữu ích?

more options

What makes you think the Windows resets Firefox to Windows 8 compatibility ?

Can you attach a screenshot?

Hữu ích?

more options

When I right clicked the tiny picture and then maximize, it opened into a larger picture, but only about three inches wide, and still at the bottom. It would not open full screen when I moved the mouse pointer into it. Again, when I tried to close it, I had to close the program with the Task Manager.

The reason that I thought the program had reverted to Windows 8 was only because that was the only compatibility option shown in the Properties information. As you see, the pull-down menu is greyed out and inoperable. Windows 8 is written on the area above the pull down triangle mark. I didn't really know, but made the assumption that if it was the only option available, that must be what is is present.

Thank you for responding.

Hữu ích?

more options

There is nothing checked in the compatibility settings, so you must have a different issue.

Can you show a screenshot of your actual issue ?

Hữu ích?

more options

There is nothing to screen shot. All I would get is a picture of the desktop with icons on it.

Firefox does not open. Clicking the desktop shortcut icon creates a small thumbprint-size icon at the bottom of the screen. Putting the mouse pointer on the icon shows a small version of a screen. Putting the pointer on that small screen DOES NOT open it any further. Clicking maximize doesn't enlarge it either.

SOMETHING NEW JUST OCCURRED!

This time, when I clicked the desktop icon, the small icon appeared at the bottom as before, but there was a line of print reading something about restore downloading.

The little screen was wider than the one that appeared before, but it still will not fill the desktop when the mouse pointer is on it, nor does using maximize in right-click make it do so. I still had to use Task Manager to close. The little screen is too small to read or use.

Hữu ích?

more options

Can you enlarge the window via the system menu (Alt+Space) ?

Hữu ích?

more options

No. The small window shows only when the mouse pointer is on the icon at the bottom. Moving the pointer closes the small window.

Leaving the pointer in the small window does not keep the window open when I use the alt key and/or spacebar.

In other words, using the alt + space closes the small window.

Hữu ích?

more options

Okay, I think you'll need to do this the harder way.

Using the Run dialog (windows key + R) or the Windows search box, type or paste the following and press Enter to drill down to the Profiles folder:

%APPDATA%\Mozilla\Firefox\Profiles

Here you may see one folder -- in which case, double-click into that -- or more than one folder -- in which case, double-click into what looks like the most recently updated.

Scroll down and right-click > Rename xulstore.json to something like xulstoreOLD.json just in case you need it later.

Start Firefox back up again. Do windows display normally again?

That mini-reset may hide the menu bar and bookmarks toolbar. You can use one of these methods to show the toolbar list and select the desired bars there:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

To turn on the Bookmarks Toolbar or Menu Bar, click it on the list.

Hữu ích?

more options

I did as you said.

When I tried to reopen Firefox, a full-size screen came up. It was white and had a message that my last session was not restored. There was a "Restore Session" link that I clicked. The window closed and never reopened.

I double clicked my short-cut icon again. This time, the same thing happened as before -another icon shows at the bottom of the screen, and when the mouse pointer is put on it, small screen (about three inches wide) opens. Pointing on it does not make it full size. It disappears as soon as the mouse pointer moves away. I still need to close that icon with the Task Manager.

Hữu ích?

more options

Hmm, maybe something bad is getting restored. That restore page usually has a button/link to show a list of your last session windows and tabs so you can be more selective. Do you think that would be worth a try, if renaming xulstore.json lets you get back to it again?

Hữu ích?

more options

I'm willing to retry, but if something got into it, I suppose it would be safer to just uninstall it and install a new version.

Before this happened, I remember seeing a very quick message about updates when I opened Firefox. It didn't look exactly like the others that normally appear. I wondered why it went by so fast. Perhaps it would be better not to restore it.

Will uninstalling it remove all folders that belong to Firefox, so that nothing remains of any malware?

Hữu ích?

more options

I don't suspect malware at this point, but possibly a page being restored is crashing Firefox in a weird way. So one option would be to prevent that from happening by skipping some or all of the restore.

Another thing:

Have you tried starting Firefox in its Safe Mode? That prevents add-ons from running, which may or may not improve the situation. To do that, after closing/crashing Firefox:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hữu ích?

more options

This is new to me. Before I try this, after I start in safe mode, how to I get out of it? Does this put my whole PC into safe mode?

Hữu ích?

more options

This only starts Firefox in Safe Mode. To return to normal, exit Firefox, then the next time you start it, don't hold down the Shift key.

Hữu ích?

more options

In safe mode, the page opens to a normal size. However, after closing, I restarted it and it reverted to the icon at the bottom that I had to close with task manager.

Hữu ích?

  1. 1
  2. 2
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.