Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Video screen spos up as I scroll down the page

  • 4 trả lời
  • 1 gặp vấn đề này
  • 40 lượt xem
  • Trả lời mới nhất được viết bởi johnhwin

more options

When I open a page with a video, such as CNN RSS feed, the video at the top of the page pops up, in a smaller size, as I scroll down the page. How do I stop that.

When I open a page with a video, such as CNN RSS feed, the video at the top of the page pops up, in a smaller size, as I scroll down the page. How do I stop that.
Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (4)

more options

That fixed mini player is a feature offered by the website and is created via JavaScript if the main player is scrolled out of view.

A lot of websites now have a fixed (pop-up) mini player once you start plying a video in one the corners that stays visible if you scroll the page. This website mini player shouldn't be confused with the Firefox PiP (picture-in-picture) feature (you likely see the PiP icon if you hover the player).

You might be able to block such a mini player pop-up via a content blocking extension.


You can look at these prefs on the the about:config page to see what settings work for you to block autoplay.

  • media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


more options

Thank you for your help. Tried your suggestions, The mini player still shows up as I scroll down the page.


Setting media.autoplay.default = 5 prevented the video from starting all together. I Changed to media.autoplay.default = 2. Is this the right thing to do?

more options

Hi

I'm not sure in what way media.autoplay.default = 2 is working.

Does that give you a doorhanger asking for permission to play the video ?

media.autoplay.default = 5 should prevent the video from starting to play automatically, but the video should start if you click the play button. This doesn't prevent the mini player from showing if you scroll, but you shouldn't see this player as long as no video has been started.

more options

I have the same thing happening. using microsoft edge on the same web sites it doesn't happen. I tried all the solutions allready given.

I attached a screen shot