Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

My only search engine in firefox is google but automaticaaly switches over to BING

  • 7 trả lời
  • 1 gặp vấn đề này
  • 174 lượt xem
  • Trả lời mới nhất được viết bởi jscher2000

more options

I have been using Firefox for many years now and it uses Google, but for the past week or so when I have typed in my search it automatically switches it to BING search. I have checked all my settings and programs but BING is not listed, so why the automatic change over, and how can I fix the problem?

Giải pháp được chọn

If the Add-ons page is blank, one of the extensions might be interfering with access. Try again in Firefox's Safe Mode. In Safe Mode, the extensions are deactivated so they can't interfere. Here's how you get there:

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

If Firefox is not running, or the above is blocked: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Can you get to the Add-ons page and clean out anything suspicious or unknown?

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (7)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ Bing “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

Hữu ích?

more options

Robin S said

FredMcD replied to my Bing problem with Firefox, but sadly despite trying several ways as soon as I click on add-on my page just goes blank. Tools add-on same blank page, same with Firefox page click on the three lines scroll down to add on blank screen comes up. When I googled this problem there were several videos that stated it was a virus, I have Malwarebytes premium so I have also contacted them for their assistance. Bing or any other of the sites listed SafeSearch etc. none are listed in my files list so nothing to delete. Is it worth deleting Firefox and then next day download it fresh, or is the bad add-on just lurking ready to attach itself again.

Hữu ích?

more options

You may have ad/mal-ware. Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed free to use malware scanners. Each works differently. If one program misses something, another may pick it up.

Hữu ích?

more options

Giải pháp được chọn

If the Add-ons page is blank, one of the extensions might be interfering with access. Try again in Firefox's Safe Mode. In Safe Mode, the extensions are deactivated so they can't interfere. Here's how you get there:

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

If Firefox is not running, or the above is blocked: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Can you get to the Add-ons page and clean out anything suspicious or unknown?

Hữu ích?

more options

Thank you thank you, your suggestion worked 100% and successfully removed what ?? was causing the problem. Does that mean now I have to switch to Safe Mode each time I click on Firefox?

I am 80 years of age but fairly computer literate, but this virus? sure had me beat. I hated BING before but now i hate it even more>

Hữu ích?

more options

See if you still get the error. If not, you are all set.

Hữu ích?

more options

Robin S said

Thank you thank you, your suggestion worked 100% and successfully removed what ?? was causing the problem. Does that mean now I have to switch to Safe Mode each time I click on Firefox?

Unfortunately, the relief brought by Safe Mode is temporary. You still need go to the Add-ons page and review your extensions and clean out whatever is causing the problem in regular (non-Safe) mode before you can rid your Firefox of the problem.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.