Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Disably overly insisting updates

  • 9 trả lời
  • 1 gặp vấn đề này
  • 159 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

When Firefox asks if I want to download an update and I agree, soon after that but not right away it stops working - on every new page it says "we need to restart to finish updating" <- this last bit is VERY annoying. Is there a way to keep FF working in such situation? I usually have 3 FF profiles running, about 10-20 tabs each and when it suddenly does this - I can restart them all but when it is suitable for me.

The only solution I can see so far is disabling updates via group policies (which is not well documented, where do i put this policies.json on fedora? need to google that).

Any other ways to keep updates and FF running until I decide when to restart? Thanks.

Giải pháp được chọn

aikbox said

I have added a policy file with "AppAutoUpdate false" and I keep receiving popups about available updates, is there a way to stop those? Or it is not possible for betas?

Hi, the policy you need to use is 'DisableAppUpdate' https://github.com/mozilla/policy-templates/blob/master/README.md

 {
  "policies": {
    "DisableAppUpdate": true
  }
}

You can disable the policy by changing true to false.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (9)

more options

I suggest: do not accept the download until you are ready for the restarts. Don't worry about missing out, you can always go to the Help > About Firefox menu to trigger the update.

I suspect the unwanted pages are related to running multiple profiles at the same time. My main profile where I accept downloading the update understands that I want to wait, and I've never been forced to restart. However, if I start Firefox in another profile during that time and the update actually installs right then, I think it's not safe to keep working in my main profile without doing the restart since the program files running in memory won't match what is on disk. I usually do not wait to see the message you're seeing or risk other consequences.

more options

What you suggested is rather a workaround.

If I do not accept the download, then I have 3 annoying popups (not 1 but 3). Also auto update thingy did not bother suggesting to update my v76 to something better, I got distracted a bit and then found we are on v84 now so it looks like the whole autoupdate thing needs manual intervention anyway.

Furthermore one of FFs is purely for reading local trusted PDFs, that profile does not need security updates but I have to restart that too.

more options

aikbox said

Also auto update thingy did not bother suggesting to update my v76 to something better, I got distracted a bit and then found we are on v84 now so it looks like the whole autoupdate thing needs manual intervention anyway.

Maybe it's a settings issue because most users don't wait over 6 months to update. Actually, I'm puzzled that your Firefox is identifying itself to the forum as version 85. Are you on the beta channel, or running Developer Edition? If you prefer less frequent updates, that wouldn't be the first choice.

Furthermore one of FFs is purely for reading local trusted PDFs, that profile does not need security updates but I have to restart that too.

There is only one program folder that is used to create all the processes for as many profiles as you use. Actually, there are different programs for the regular release, Developer Edition, Nightly release, and the Extended Support Release of Firefox 78. So in theory you could run your profiles independently.

I should mention that I run Windows and am not familiar with all the idiosyncrasies of Linux builds.

more options

The Beta and DE haven't been updated during the holidays, so you shouldn't have been prompted if you are on either update channel. If you haven't updated for a long time then you can also be on the Nightly updated channel that receives updates twice a day (this continued even during the recent holidays).

You can check the update channel on the "Help -> Troubleshooting Information" (about:support) page and via "Help -> About Firefox".

more options

I have added a policy file with "AppAutoUpdate false" and I keep receiving popups about available updates, is there a way to stop those? Or it is not possible for betas?

more options

That policy doesn't prevent downloading and installing an update. You are merely prompted whether you want to install a downloaded update, similar to the setting in Options/Preferences (about:config => app.update.auto).

more options

app.update.auto=false for ages so is that it, no knob to stop downloading updates?

more options

Giải pháp được chọn

aikbox said

I have added a policy file with "AppAutoUpdate false" and I keep receiving popups about available updates, is there a way to stop those? Or it is not possible for betas?

Hi, the policy you need to use is 'DisableAppUpdate' https://github.com/mozilla/policy-templates/blob/master/README.md

 {
  "policies": {
    "DisableAppUpdate": true
  }
}

You can disable the policy by changing true to false.

more options

It is of no use if you are using a Beta version and disable updates via the DisableAppUpdate policy. The Beta update channel receives an update twice per week and it is important to use the latest version and with this policy you can't update in any way apart from downloading and installing a next update If you do not want these updates then you should switch to the release update channel.