Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

DNS & IP leaks in Firefox 84, 64-bit in Linux Mint 20 using 2 different VPN's; why does Firefox leak?

more options

I'm having to currently use a different browser (not the top 3),because of these leaks. How can Firefox 84 be configured for NO leaks DNS or IP?

I'm having to currently use a different browser (not the top 3),because of these leaks. How can Firefox 84 be configured for NO leaks DNS or IP?

Tất cả các câu trả lời (4)

more options

What are you seeing with DNS? Does it matter whether your Firefox is configured for DNS over HTTPS or not? See: Firefox DNS-over-HTTPS.

For WebRTC leaks, you can modify a setting. I haven't looked at this for ages, but here's an older post and you can test whether it still works: https://support.mozilla.org/questions/1303685#answer-1348340

more options

I'm using a very well supported VPN (Surfshark); to eliminate IP leaks I had to go into the sysctl.conf file & add 4 lines to essentially disable IPv6 from leaking. The DNS issue was temporarily solved by changing to Python-based browser. I will run through you suggestions tomorrow & give you feedback as to what occured before calling it solved.-DG

more options

These are the links where I test for IP & DNS leaks: https://surfshark.com/dns-leak-test https://surfshark.com/what-is-my-ip

I ran thru your 2 links using only https:// settings in Firefox & the "about:config" changes. When I go to the above 2 links, leaks still show.

Powering down, then back into Linux Mint 20, I found in my "not big 3" browser that DNS leaks checks passed. Now, though, IP leaks failed in the IPv6 area. Back to VPN support.

more options

I wonder whether some connection settings need to be adjusted in Firefox? In the same dialog where you choose DNS over HTTPS (or not, in your case), there are proxy settings, in case those are relevant to using SurfShark.