Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Open PDF not download

  • 2 trả lời
  • 1 gặp vấn đề này
  • 135 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I've changed my settings to open PDFs in a browser window rather than download and open them in adobe but I'm still not able to to so. I keep having to switch to Chrome to view a PDF and it's seriously annoying. Can anyone help

Thanks!

I've changed my settings to open PDFs in a browser window rather than download and open them in adobe but I'm still not able to to so. I keep having to switch to Chrome to view a PDF and it's seriously annoying. Can anyone help Thanks!

Tất cả các câu trả lời (2)

more options

Could you explain this problem in more detail? Here is what I mean:

When you open a link to a PDF, three things can happen:

(1) The server allows the browser to retrieve the PDF as web content. Firefox will follow your instructions on the Preferences page. If you have Open in Firefox set, Firefox will save the file in the web cache with other files collected during browsing.

(2) The server tries to force the browser to download the file by setting the Content-Disposition header to "attachment". Firefox will show the dialog letting you choose between Open in Firefox, Open (in another app), and Save. If you choose either Open, Firefox will save the file in your system's Temp folder.

(3) The server doesn't indicate that the file has Content-Type application/pdf so Firefox doesn't follow your rules for handling PDFs. Instead you get the standard Download dialog with Open and Save.

Are you seeing one of those scenarios, or something else entirely?

Note: If #1 isn't working for any PDF on any site, could you check this setting as well:

(a) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(b) In the search box in the page, type or paste pdfjs and pause while the list is filtered

(c) If the pdfjs.disabled preference is bolded and has a value of true, double-click it to restore the default value of false

more options

You can check these prefs on the about:config page.

  • browser.helperApps.showOpenOptionForPdfJS
  • pdfjs.handleOctetStream