Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Can't connect to Google.com, potential security issue

  • 6 trả lời
  • 1 gặp vấn đề này
  • 60 lượt xem
  • Trả lời mới nhất được viết bởi jscher2000

more options

I can't seem to connect to Google.com anymore. I get

Did Not Connect: Potential Security Issue

Firefox detected a potential security threat and did not continue to www.google.com because this website requires a secure connection.

What can you do about it?

www.google.com has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site.

The issue is most likely with the website, and there is nothing you can do to resolve it.

If you are on a corporate network or using anti-virus software, you can reach out to the support teams for assistance. You can also notify the website’s administrator about the problem.

as the error. I've tried various things like deleting certificates, refreshing firefox, and even uninstalling firefox. Nothing works and I don't want to go back to Edge. Google.com works fine on edge, and I have a document saved as a start up tab that works fine on firefox. Drive also doesnt work, but accounts.google.com works so I can sign in.

Tất cả các câu trả lời (6)

more options

Sorry for the hassle. Here's how to investigate the problem further:

On the error page, you usually will find an "Advanced" button that leads to more technical information. This includes:

(1) An error code like SEC_ERROR_SOMETHING

Let us know what you're getting, and this article has more info on troubleshooting: How to troubleshoot security error codes on secure websites.

(2) A View Certificate button

This button open a new tab with the details of the certificate that Firefox doesn't like (if it's a certificate issue). Google issues its own certificates, so you can check the "Issuer Name" section and you should find something similar to this:

Common Name: GTS CA 1O1

If you see something that isn't Google, most likely there is a "man in the middle" of the connection. Sometimes the name tells you, sometimes it doesn't.

Hữu ích?

more options

jscher2000 said

Sorry for the hassle. Here's how to investigate the problem further: On the error page, you usually will find an "Advanced" button that leads to more technical information. This includes: (1) An error code like SEC_ERROR_SOMETHING Let us know what you're getting, and this article has more info on troubleshooting: How to troubleshoot security error codes on secure websites. (2) A View Certificate button This button open a new tab with the details of the certificate that Firefox doesn't like (if it's a certificate issue). Google issues its own certificates, so you can check the "Issuer Name" section and you should find something similar to this: Common Name: GTS CA 1O1 If you see something that isn't Google, most likely there is a "man in the middle" of the connection. Sometimes the name tells you, sometimes it doesn't.

I get SEC_ERROR_UNKNOWN_ISSUER and it seems to have DigiCert Global Root G1A as the Common Name. I've deleted the certificate file a couple times but it hasn't fixed anything. Is there something I can do?

Hữu ích?

more options

The problem isn't in the certificate file, it's that the certificate the web server is presenting to Firefox isn't a verifiable certificate.

I've seen that certificate mentioned in the following thread, but don't understand the source: https://www.reddit.com/r/firefox/comments/jyxq4e/i_can_t_access_google_and_related_sites/

You can check the proxy setting here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Network Settings" section. Click the "Settings" button.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Any difference?

Hữu ích?

more options

jscher2000 said

The problem isn't in the certificate file, it's that the certificate the web server is presenting to Firefox isn't a verifiable certificate. I've seen that certificate mentioned in the following thread, but don't understand the source: https://www.reddit.com/r/firefox/comments/jyxq4e/i_can_t_access_google_and_related_sites/ You can check the proxy setting here:
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it
In the search box at the top of the page, type proxy and Firefox should filter to the "Network Settings" section. Click the "Settings" button. The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy". Any difference?

That ended up fixing it, but if it caused a problem with google and Firefox was able to catch it, might there be an issue with other connections that i should be worried about?

Hữu ích?

more options

jscher2000 said

The problem isn't in the certificate file, it's that the certificate the web server is presenting to Firefox isn't a verifiable certificate. I've seen that certificate mentioned in the following thread, but don't understand the source: https://www.reddit.com/r/firefox/comments/jyxq4e/i_can_t_access_google_and_related_sites/ You can check the proxy setting here:
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it
In the search box at the top of the page, type proxy and Firefox should filter to the "Network Settings" section. Click the "Settings" button. The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy". Any difference?

Looks like that fixed it, but if there's something wrong with my proxy settings that google couldn't be authenticated, might it cause issues with connections outside firefox?

Hữu ích?

more options

Your post was delayed by the link moderation feature (non-Mozilla URLs in a reply cause that).

If "Use system proxy settings" causes the problem, then you might want to look at your Windows 10 networking/connection settings. However, I haven't kept up with the changes in that area, so I'm not sure how best to investigate.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.