Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Site blocked because "not secure"... How to force/bypass this beeep feature ?

  • 7 trả lời
  • 1 gặp vấn đề này
  • 8 lượt xem
  • Trả lời mới nhất được viết bởi cyborga41

more options

Hello,

Firefox is blocking some website because it says it's not secure (see picture). I don't give a .... So I want to access the website anyways. However, there is NO way to do that, NONE. I've searched everywhere. So I can only rely on you guys. How can I force the connection or bypass the F security, or get rid of it, or something... anything.

Here is a historic of my tests : My issue is simple. 2 days ago I could surf on some website completely fine. Then all of a sudden half my website get SO CALLED "The connection has timed out".

- Test server : So I go on the usual website-server-is-down to test if the server is down. The website itself is perfectly fine according to 5 testing website. - Test server 2 : Then I go through a "browser inside browser" website to test it again (dunno how it's called). I can access the main page then navigate fine on all test-browser. The website is therefore fine. - "Not secure" : Despite the viciously misleading message saying "connection timed out" that makes you believe the website is down and gone, it is actually fine, as proven above. It's just for some god unknown reason Firefox decided to block it, without telling you it's actually blocking it (nice move!). - No button : I searched but could not find a way to either force the connection or create security exception. I tried disabling all security in "privacy" tab in the option, no deal. - Certificate : I also went to try and add the website as an exception in the certificate list, but Firefox pretends it cannot connect to the website, therefore you cannot add the certificate. - Security.enterprise : I have removed the access from Avast to Firefox allowing me to unlock security.enterprise_roots.enabled. Once I had it unlocked, I tried either True or False, but no deal (including reboots comp & browser) - I spent 4 hours searching solutions on the web, but couldn't fin any. Is Firefox actively preventing me for surfing the web as I like... ?

In the end, I still cannot access this website. And I wanna say to Mozilla : It's my own liberty if I want to go and shoot myself in the foot by visiting a so-called "unsecured website". I should be able to do so if I want to...

Anyway, if any gosu out there has the skill, please help ? ^^; Thanks

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

It is difficult to diagnose the reason for time-outs. If you use DNS over HTTPS, try turning it off to see whether that makes any difference: Firefox DNS-over-HTTPS.

After the change, you may want to clear Firefox's DNS cache. You can paste this internal address in the address bar and press Enter to load it:

about:networking#dns

There should be a button to clear the DNS cache in the top half of the page.


On the other two topics:

Windows 7 supports Internet Explorer 11, so you can update your alternate browser. https://support.microsoft.com/en-us/topic/download-internet-explorer-11-offline-installer-99d492a1-3a62-077b-c476-cf028aff9a7f

Avast WebShield doesn't use policies or settings, it sets up as a man-in-the-middle of your connection. For example, on this site, if you check the certificate through the Page Info dialog -- either

  • Ctrl+i
  • right-click a blank area of the page > View Page Info
  • (menu bar) Tools > Page Info

-- then click Security, then View Certificate, the issuer name should show up as Amazon (since this site is hosted on AWS). If WebShield were running, you will see that the issuer is Avast instead.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (7)

more options

I'm sorry, I forgot to add the fake "connection timed out" given by Mozilla to hide the blocking of the website :

(See picture)

Hữu ích?

more options

If Firefox says the connection timed out, then you are not connected, and any indication about whether the connection is secure or insecure is therefore not useful information.

Any difference if you disable the Avast WebShield (either completely, or not applying it to Firefox connections)?

Do you use any proxy?

I assume Internet Explorer on the same machine can access the problem sites normally?

Hữu ích?

more options

Hello,

The internet connection is perfectly fine of course, since I can post here with the same computer/browser.

I do not have the premium Avast with the webshield, I only have the basic scan function and files protection. Also, I have removed the Mozilla folder in my hkey local policies, so that the browser can be "free" of any enterprise policy (including Avast), therefore it does not apply in this case.

I do not use proxy.

The internet explorer version I have is IE 8. It is completely outdated, since I use win7 and disabled all updates except for forced small KB. To test the site through another browser, I used a web emulator : https://www.browserling.com/ Though slow (that part is normal with cross browser), I could navigate the website without problem.

Hữu ích?

more options

Hello,

The internet connection is perfectly fine of course, since I can post here with the same computer/browser.

I do not have the premium Avast with the webshield, I only have the basic scan function and files protection. Also, I have removed the Mozilla folder in my hkey local policies, so that the browser can be "free" of any enterprise policy (including Avast), therefore it does not apply in this case.

I do not use proxy.

The internet explorer version I have is IE 8. It is completely outdated, since I use win7 and disabled all updates except for forced small KB. To test the site through another browser, I used a web emulator : https://www.browserling.com/ Though slow (that part is normal with cross browser), I could navigate the website without problem.

Hữu ích?

more options

Giải pháp được chọn

It is difficult to diagnose the reason for time-outs. If you use DNS over HTTPS, try turning it off to see whether that makes any difference: Firefox DNS-over-HTTPS.

After the change, you may want to clear Firefox's DNS cache. You can paste this internal address in the address bar and press Enter to load it:

about:networking#dns

There should be a button to clear the DNS cache in the top half of the page.


On the other two topics:

Windows 7 supports Internet Explorer 11, so you can update your alternate browser. https://support.microsoft.com/en-us/topic/download-internet-explorer-11-offline-installer-99d492a1-3a62-077b-c476-cf028aff9a7f

Avast WebShield doesn't use policies or settings, it sets up as a man-in-the-middle of your connection. For example, on this site, if you check the certificate through the Page Info dialog -- either

  • Ctrl+i
  • right-click a blank area of the page > View Page Info
  • (menu bar) Tools > Page Info

-- then click Security, then View Certificate, the issuer name should show up as Amazon (since this site is hosted on AWS). If WebShield were running, you will see that the issuer is Avast instead.

Hữu ích?

more options

Hữu ích?

more options

Hello,

Jscher2000, I want to thank you very much, your solution of DoH worked !

When I tried to run the website through TOR, it also worked, so I figured it could have something to do with local restrictions rather than the browser. After reading your solution I gave it a try and it worked.

Again, thank you very much, I can finally access many blocked website ^^. As for reference, it was only streaming, korean webnovels, and torrent websites that were suddenly out of reach.

Have a good day !

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.