Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

YouTube does not work properly when logged

  • 5 trả lời
  • 1 gặp vấn đề này
  • 33 lượt xem
  • Trả lời mới nhất được viết bởi Kamil

more options

Hello, I have problem with YouTube. When I am clicking "Share" button I got screen with infinite loading. The same issue happens when I want to open menu by clicking on my avatar. On dev console I am getting a POST error: https://developer.mozilla.org/en-US/docs/Web/HTTP/Status/401

I tried to: - clean Google/youtube cookies and stored cache; - clean then all cookies; - relaunch Firefox with all addons disabled; - enter via private mode with/without addons; - flush dns on dev console; - disable completely antivirus; - change DNS.

What is interesting, that problem happens only when I am logged in to my Google (YouTube) account and only on Firefox. Even on private mode it works until I do not log in to my account.

I would be very grateful for help.

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

You can ignore my previous reply that was meant for another thread.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (5)

more options

Giải pháp được chọn

You can ignore my previous reply that was meant for another thread.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Hữu ích?

more options

Hello cor-el. Thank you for your answer.

As I said on main post I tried to disable addons or launch in private mode and even Safe Run (without Refresh as you said) -> did not help.

I tried to refresh site with cache (CTRL+F5) -> problem remains.

I checked Enhanced Tracking Protection - nothing was blocked but I disabled it -> didn't help.

I tried to remove YouTube cookies (problem remains) so I deleted them all. Also I tried to delete (just move) file cookies.sqlite. It worked until I logged into my YouTube account again.

Also I tried to clear all cache data or restore to default theme. Still.

What is interesting, rarely it works. There is no rule when it will work and when it won't.

I had opened over 20 different videos and nothing worked but few minutes later I opened new wideo and both "Social share" and menu worked.

I am using custom userChrome.css and userContent.css files - they should be ignored in Safe Run but I deleted it and restarted Firefox. As can be deduced the problem remains.

Do you have any other ideas?

Hữu ích?

more options

Are you possibly using a special theme in YouTube in case you can configure this appearance ?

Hữu ích?

more options

I am using Stylus .css simple themes for YouTube - Colourful YouTube Ratings and Berny23's YouTube Enhancements (smaller video previews on main site) but even when I had disabled them or even entire Stylus addon (along with other addons and reboot browser) the issue remained.

userChrome.css and userContent.css are used for tabs on bottom (like on older versions of Firefox) and to make dark sites: about:newtab and about:blank otherwise they blink for a split second while opening new blank tabs or pages before their css is loaded. I am a fan of dark themes on my favorite sites and this effect annyoed me.

But as I mentioned - everything was disabled/moved to "close-vanilla-Firefox" but without success.

Được chỉnh sửa bởi Kamil vào

Hữu ích?

more options

I finally solved the issue.

It was caused by... Kaspersky, v. 21.1.15.500. Despite disabling protection on Kaspersky, or even entire antivirus, there were "invisible" still scripts that it is injecting into pages. That option is called "Inject script into web traffic to interact with web pages option under Traffic processing".

Disabling that option or updating Kaspersky to newer version helped.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.