Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Problem with encoding

  • 8 trả lời
  • 1 gặp vấn đề này
  • 23 lượt xem
  • Trả lời mới nhất được viết bởi michaelgoldman123

more options

Hi there, I have a new computer working under Ubuntu. When using Firefox I often have a problem with the characters which appear when I open webpages or even read pdf documents. This isssue does not seem to happen in a very consistent way (some websites will appear correctly one day and incorrectly another day). I include below a screenshot as example. The problem does not seem to appear with chromium... If you have any idea about how to fix this I would be very grateful Thanks Michael

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

As a test you can try to disable the Italic style for this element.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (8)

more options

Hi Michael, for the photo caption, when I check the site, it says the photo caption is Arial Bold Italic. Could you compare on yours using the Page Inspector tool:

  • right-click the unicode boxes and choose Inspect Element
  • after Firefox opens the Inspector, on the right side, change from the displayed panel to the Fonts panel (you may need to use a little triangle at the end of the bar that says Rules Layout Computed Changes Fonts Animations)

Here Firefox should show what the page calls for and what Firefox is actually using for that element.

Hữu ích?

more options

Giải pháp được chọn

As a test you can try to disable the Italic style for this element.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Hữu ích?

more options

Hi, thanks for your answers. When I disable the italic on the element it appears correctly. How can I globally disable the use of italic with Firefox?

Hữu ích?

more options

Disabling Italic was merely meant as a test.

We have seen cases where Firefox tries to use the Twemoji font that only includes emojis and not normal ASCII characters for displaying Italic text.

Is this happening in your case as well if you check the font that is used in the Font tab in the Inspector like suggested above ?


Được chỉnh sửa bởi cor-el vào

Hữu ích?

more options

yes, this seems to be indeed the problem (Firefox using Twemoji font). From your answers on the other threads, do I interpret correctly that there is no known fix to this issue? thanks again for your help!

Hữu ích?

more options

You can try to set gfx.e10s.font-list.shared = false on the about:config page.

Hữu ích?

more options

unfortunately it was already set to false

Hữu ích?

more options

PS tried to changed it to true and it did not change anything...

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.