Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

block autoplay not working in firefox 82.0 (linux)

  • 1 trả lời
  • 1 gặp vấn đề này
  • 18 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I don't understand why firefox makes it so difficult to stop websites from autoplaying videos. Case in point: fox news and fox business news web sites. They have that stupid pop up when you scroll down the page, so if the main video is blocked the popup ignores it and starts playing. The preferences->autoplay doesn't allow you to enter a site to block and clicking on the lock on the url bar doesn't work because the permissions line isn't clickable, so we are left to resort to about:config which also fails to block these sites. This is very frustrating and if anything will drive me to another browser its stuff like this.

I don't understand why firefox makes it so difficult to stop websites from autoplaying videos. Case in point: fox news and fox business news web sites. They have that stupid pop up when you scroll down the page, so if the main video is blocked the popup ignores it and starts playing. The preferences->autoplay doesn't allow you to enter a site to block and clicking on the lock on the url bar doesn't work because the permissions line isn't clickable, so we are left to resort to about:config which also fails to block these sites. This is very frustrating and if anything will drive me to another browser its stuff like this.

Tất cả các câu trả lời (1)

more options

You can look at these prefs on the the about:config page to see what settings work for you to block autoplay.

  • media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.