Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Cannot change the start up page

  • 9 trả lời
  • 1 gặp vấn đề này
  • 19 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

Hi there My start up page jhas been hijacked by v9-ap.com and keeps on showing a page for a turkish site 'Lider Haber'

I have tried refreshing, using adaware and all sorts of anti virus

Mozilla cfg is // lockPref("browser.startup.page", 1); lockPref("browser.startup.homepage", "http://v9-ap.com?s=92663E31&p=54484550555A5A4C4559532D5043&g=5406EFB439567CFB70247BF3C02E9A31"); lockPref("pref.browser.homepage.disable_button.current_page", true); lockPref("pref.browser.homepage.disable_button.restore_default", true); lockPref("pref.browser.homepage.disable_button.bookmark_page", true);

Any ideas? I have even uninstalled and re-installed

Giải pháp được chọn

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Type browser.startup.homepage

What is the value? Right-click and select Reset to restore its default value; about:home

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (9)

more options

You may have ad/mal-ware. Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed free to use malware scanners. Each works differently. If one program misses something, another may pick it up.

Hữu ích?

more options

Giải pháp được chọn

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Type browser.startup.homepage

What is the value? Right-click and select Reset to restore its default value; about:home

Hữu ích?

more options

Thanks Fred

that appears to have done the trick

Hữu ích?

more options

Glad to help. Safe Surfing.

Hữu ích?

more options

Note that as long as you have a working autoconfig.cfg file (mozilla.cfg in your case) with a lockPref() call, you won't be able to modify this pref on the about:config page.

You need to remove the .js file in defaults\pref that specifies to use the autoconfig.cfg file and the autoconfig.cfg file in the main Firefox installation folder to be able to reset the pref on the about:config page.

Hữu ích?

more options

Cor-el and FredMcD

Yes This is right, its there and is greyed ut and padlocked

How do u access defaults\pref and I assume you mean the Firefox folder in program files?

Can i just safely delete a .js file there?

Thanks for your help

Hữu ích?

more options

There should only be a channel-prefs.js in the defaults\pref folder in the Firefox program folder, any other file there is suspicious and you can open this file in a text editor for inspection. Do not double-click Firfox .js files as that will cause Windows trying to run this file as a JScript file what fails.

You may see a .js file with this content (the filename can differ) that causes an autoconfig file

//
pref("general.config.filename", "autoconfig.cfg");
pref("general.config.obscure_value", 0);

Hữu ích?

more options

Hey cor-el

I have a local-settings.js which when dragged into notepad contains

pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg");

Hữu ích?

more options

You can remove the local-settings.js file in the defaults\pref folder and the mozilla.cfg file in the main profile folder.

You will have to reset the prefs you posted in the above question that are set via mozilla.cfg on the about:config page.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.