Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Ticketprinter prints only the name of the print job in version 82

  • 7 trả lời
  • 1 gặp vấn đề này
  • 24 lượt xem
  • Trả lời mới nhất được viết bởi Compart

more options

Since the release of version 82 we cannot print on a ticket printer. We use the silent printing solution from Firefox but then it prints a small ticket with only the name of the printjob on. When we disable the silent printing and click manually on the ok button in the print dialog it does work but that is not an option, we need the silent printing to process the printjobs of orders.

What can I do to make this work again? The issue is with all types and brands of ticketprinters.

In Google Chrome or with version 81 everything works great. We use Firefox on hundreds of computers so it is impossible to downgrade them all.

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Hello, I think we found the problem and also the solution in the about:config for the star TSP 654 printer. Changing the paper size solved the problem. The test is done on 2 computers, now we need to check if this is the solution for all computers.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (7)

more options

This looks like https://bugzilla.mozilla.org/show_bug.cgi?id=1672370 which we have a patch for. I'm hoping we will release a Firefox 82.0.1 with this fix (I don't make these decissions), but that will take at least a couple of days to get out.

In the meantime, one thing you could try experimenting with is turning on the new printing UI by opening the page `about:config`, typing in "print.tab_modal.enabled", and toggling that preference to `true`. You will then get the new printing user interface (not yet complete, but possibly(?) good enough for your purposes). We've had reports from some users that this new interface works for receipt printing with their receipt printers. I'd be very interested to hear back about whether it does or does not for you, and the details of what you tried and what worked/didn't.

It would also help us to know which printer models you're using, and which (if any) work with the new printing interface.

Hữu ích?

more options

Note that in the new interface you can expand the "More settings" area to get a "Paper size" option where you can select the paper size. You may for now need to select the paper size each time you print. :-/ (Let us know if that's the case.)

Hữu ích?

more options

Thanks for your answer but it was unfortunately not solved by setting the parameter "print.tab_modal.enabled" to true. I have already tested with different paper sizes but once the silent printing is enabled, it no longer prints the content of the receipt only the small ticket with the name of the print job.

An exmple model of printer is Star Micronics receipt Star TSP 100 & TSP650II

Hữu ích?

more options

Can you clarify whether when you're turning silent printing off you also need to manually select the correct paper size **every** time you print, or whether with silent printing off it just works without needing to do that? It sounds like the latter since you didn't mention having to manually set the paper size each time, but if that's the case we're confused about why that would happen, and we would need to dig deeper.

Regarding a temporary workaround for you, it would be good to know what the prefs in `about:config` are set to in a working Firefox 81 (I guess these may vary for different printer models, unfortunately):

``` print_paper_height print_paper_id print_paper_name print_paper_size_unit print_paper_width ```

I think it's possible that if you turn off silent printing, do a successful print, then set the pref `print.always_print_silent` back to `true` and **also** set the pref `print.save_print_settings` to `false`, that will make subsequent silent prints use the correct settings and also stop those settings being reverted.

If that doesn't work then it may require setting the above five prefs manually to the correct values (obtained from Firefox 81 for the given printers) and setting `print.always_print_silent` back to `true` and **also** set the pref `print.save_print_settings` to `false`, all in one go.

Hữu ích?

more options

Giải pháp được chọn

Hello, I think we found the problem and also the solution in the about:config for the star TSP 654 printer. Changing the paper size solved the problem. The test is done on 2 computers, now we need to check if this is the solution for all computers.

Được chỉnh sửa bởi Compart vào

Hữu ích?

more options

That's great to hear. Can you clarify exactly what steps you take and settings (with values) you set on each computer to get things working for you?

Hữu ích?

more options

You need change the paper size since the default paper size gives this problem. After changing that it works again.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.