Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Disable or erase "Recently Bookmarked"

  • 8 trả lời
  • 3 gặp vấn đề này
  • 160 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

I want to erase or preferably disable the "Recently Bookmarked" functionality when you go to the bookmarks part of the library. How do I do this? I don't see anything in the Support, despite doing searches using several different search terms. It is a strange thing to have without being able to erase it or disable it, especially since bookmarks saved during "private window" searches show up there.

Tất cả các câu trả lời (8)

more options

Enter about:config in the URL bar and set browser.library.activity-stream.enabled = false.

Hữu ích?

more options

The menu is still populated, and I bookmarked another page and it showed up in Recently Bookmarked.

I restarted Firefox and checked Advanced Preferences. It shows that setting as "false" but still allows the Recently Bookmarked to populate and add new bookmarks.

Hữu ích?

more options

Ah, you want to remove the second list. I don't think it's removable. You can only remove the whole Library and add Bookmarks and History instead, by using the ≡ -> Customize menu.

Hữu ích?

more options

Well, that explains why I can't remove either Recently Bookmarked or the Library itself. I still think it is a weird oversight that it is so hardcoded in a browser that represents itself as a leading privacy guardian. Thanks, Ty.

Hữu ích?

more options

You cane Right click and delete the icon that shows recently bookmarked, then go to custom settings and add the "star above horizontal parenthesis" icon > show your bookmarks, then drag wherever you want it.

Hữu ích?

more options

I accidentally deleted "recently bookmarked" from the bookmarks menu, and wish to restore it. How do I go about this?

Được chỉnh sửa bởi starramus vào

Hữu ích?

more options

I just noticed that I have this problem too. Firefox is tracking my most recently bookmarked. I followed the steps for about:config and changed it from true to false so it won't continue tracking but how do I clear the whole list? I found the list by clicking the icon in the upper right with the 3 lines and the slanted line (see screenshot). Then I clicked Bookmarks and it shows Recently Bookmarked. Thanks. Barbara

Hữu ích?

more options

You can possibly use code in userChrome.css to hide these recent lists,


Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* hide Recently Bookmarked */
 #panelMenu_recentBookmarks,
 #panelMenu_bookmarksMenu {display:none!important;}
 #appMenu-library-recentHighlights [type="highlight-bookmark"] {display:none!important;}

/* hide Recent History */
 #PanelUI-history label[value="Recent History"],
 #appMenu_historyMenu {display:none!important;}

/* hide Recent Highlights */
 #appMenu-libraryView label[value="Recent Highlights"],
 #appMenu-library-recentHighlights {display:none!important;}

/* hide Recently Closed Tabs/Windows */
 #appMenuRecentlyClosedTabs,
 #appMenuRecentlyClosedWindows {display:none!important;}

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.