Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Right side of Firefox is cut off, does not happen in safe mode

  • 7 trả lời
  • 1 gặp vấn đề này
  • 64 lượt xem
  • Trả lời mới nhất được viết bởi s3h

more options

Hi, I've been having this issue for a few months now, and it can get really annoying. Like the title says, the right side of Firefox is cut off a little for me, both in fullscreen and windowed fullscreen. This problem occurs on all websites, and is only fixed when I restart in safe mode, though I don't think any extensions that I have could be causing this problem. Any ideas would be much appreciated.

Thanks!

Giải pháp được chọn

This doesn't seem to work as intended:

:-moz-any(#content, #appcontent) browser {
  margin-right: -17px !important;
  overflow-y: scroll;
  margin-bottom: 0px !important;
  overflow-x: scroll;
}
 

The first line seems designed to push the vertical scrollbar off the screen to the right. This is the standard scroll bar width and would be too wide on sites with narrow scroll bars.

To avoid losing content on pages that do not normally have a scroll bar, the second line tries to force a scrollbar. But that isn't working as intended.

Try it without those first two lines.

Edit

What I mean by the first two lines is removing the first two property: value assignments in the rule (second and third lines of the rule). Actually, it would be simplest to remove the whole rule (all six lines).

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (7)

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Hữu ích?

more options

Do you get a horizontal scroll bar or is the content just lost?

You had another thread a few months ago where you might have set up some rules in a userContent.css file. One of the differences between Firefox's Safe Mode and regular is that userContent.css and userChrome.css are disabled. So possibly there is an issue with one of your custom style rules. As a test, you could temporarily hide the userContent.css file from Firefox -- by renaming the file, moving it to a different folder, or renaming the chrome folder -- and see whether the issue is resolved on your next regular Firefox startup.

Hữu ích?

more options

jscher2000 said

Do you get a horizontal scroll bar or is the content just lost? You had another thread a few months ago where you might have set up some rules in a userContent.css file. One of the differences between Firefox's Safe Mode and regular is that userContent.css and userChrome.css are disabled. So possibly there is an issue with one of your custom style rules. As a test, you could temporarily hide the userContent.css file from Firefox -- by renaming the file, moving it to a different folder, or renaming the chrome folder -- and see whether the issue is resolved on your next regular Firefox startup.

Thanks for the help! It was my custom CSS messing with it.

Hữu ích?

more options

If you have questions about adjusting your CSS that you aren't able to solve, you can raise that here, but please use a site like Pastebin for the CSS or if you share it here, use <pre> before and </pre> after the code block to avoid having it interpreted as wikitext.

Hữu ích?

more options

jscher2000 said

If you have questions about adjusting your CSS that you aren't able to solve, you can raise that here, but please use a site like Pastebin for the CSS or if you share it here, use <pre> before and </pre> after the code block to avoid having it interpreted as wikitext.

Sure, here it is.

Hữu ích?

more options

Giải pháp được chọn

This doesn't seem to work as intended:

:-moz-any(#content, #appcontent) browser {
  margin-right: -17px !important;
  overflow-y: scroll;
  margin-bottom: 0px !important;
  overflow-x: scroll;
}
 

The first line seems designed to push the vertical scrollbar off the screen to the right. This is the standard scroll bar width and would be too wide on sites with narrow scroll bars.

To avoid losing content on pages that do not normally have a scroll bar, the second line tries to force a scrollbar. But that isn't working as intended.

Try it without those first two lines.

Edit

What I mean by the first two lines is removing the first two property: value assignments in the rule (second and third lines of the rule). Actually, it would be simplest to remove the whole rule (all six lines).

Được chỉnh sửa bởi jscher2000 vào

Hữu ích?

more options

Thanks very much for the help!

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.