Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Tabs now to small and behavior strange in FF 78.3esr

  • 13 trả lời
  • 1 gặp vấn đề này
  • 19 lượt xem
  • Trả lời mới nhất được viết bởi mozilla171

more options

First I have to say that I absolutely HATE HATE HATE how Mozilla breaks everything with every upgrade now. Hate it. It feels like getting bent over by IE all over again.

I upgraded from 68.something to 78.3 esr and now my tabs are teeny tiny and the one that is selected gets bigger and leaks into the web page (see pic). I already fixed the "tabs on top of everything" issue that the upgrade introduced, but now this.

How do I make my regular tabs and pinned tabs bigger like they were before? And stop the current tab from leaking over the bottom boundary into the web page?

Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (13)

more options

It looks even crappier when I try to make the tabs bigger with the Density control set to "Touch."

Now, not only is the current tab stupidly big, but the bottom of the other tabs is getting cut off.

And why is there a double line under the tabs?

I knew I shouldn't have upgraded.  :(  :(  :(  :(  :(

Hữu ích?

more options

How does it look like after setting toolkit.legacyUserProfileCustomizations.stylesheets to false in about:config and restarting the browser?

Hữu ích?

more options

TyDraniu said

How does it look like after setting toolkit.legacyUserProfileCustomizations.stylesheets to false in about:config and restarting the browser?

Looks great! Except now the tabs are above the address bar, and just under title bar, AGAIN!!!!!

Why is 2020 Firefox worse than 2010 Firefox, in every way?

Được chỉnh sửa bởi mozilla171 vào

Hữu ích?

more options

You likely have a userChrome.css in the chrome folder in the profile folder that makes some modifications to the appearance of the Firefox user interface. Setting the above mentioned pref disables userChrome.css (user interface) and userContent.css (web pages).

More info:

Hữu ích?

more options

cor-el said

You likely have a userChrome.css in the chrome folder in the profile folder that makes some modifications to the appearance of the Firefox user interface. Setting the above mentioned pref disables userChrome.css (user interface) and userContent.css (web pages). More info:

I deleted my userChrome.css (I had no userContent.css) and the tabs are still above the address bar, bookmarks bar, etc.

How do I get the tabs back below the address bar and above the bookmarks bar?

Hữu ích?

more options

mozilla171 said

Looks great! Except now the tabs are above the address bar, and just under title bar, AGAIN!!!!! Why is 2020 Firefox worse than 2010 Firefox, in every way?

It's not worse, only your css modification from 2010 is broken in 2020.

Hữu ích?

more options

By default the Tab bar is above the Navigation Toolbar. You can't get the Tab bar between the Navigation Toolbar and the Bookmarks Toolbar. You can only move the Tab bar below all the toolbars (i.e. below the Bookmarks Toolbar) via userChrome.css like you previously had when you had userChrome.css enabled.

Hữu ích?

more options

cor-el said

By default the Tab bar is above the Navigation Toolbar.

That's ridiculous. I should be able to put it where I want it.

cor-el said

You can only move the Tab bar below all the toolbars (i.e. below the Bookmarks Toolbar) via userChrome.css like you previously had when you had userChrome.css enabled.

Okay, fine, so how do I do that?

Hữu ích?

more options

The only way to move the Tab bar from the default position above the Navigation Toolbar to a lower position is by using userChrome.css like you previously had, so you will have to restore this file with code that works for you. If you have this file in the Windows Recycle bin then you can restore userChrome.css to the chrome folder, otherwise you need to create a new file.

You can look at the basic code I posted in this thread that works for me in a large range of Firefox versions (68-83).

Được chỉnh sửa bởi cor-el vào

Hữu ích?

more options

Just copied the text in questions/1305615 into a newly-created userChrome.css file in my profile. Restarted FF and still the same.  :-(

Được chỉnh sửa bởi mozilla171 vào

Hữu ích?

more options

Did you switch back the preference?

Hữu ích?

more options

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

Hữu ích?

more options

cor-el said

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.
  • toolkit.legacyUserProfileCustomizations.stylesheets = true
See:

That did it, thanks!  :-)

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.