Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

A problem with setting a new bookmark

  • 44 trả lời
  • 1 gặp vấn đề này
  • 143 lượt xem
  • Trả lời mới nhất được viết bởi reble

more options

I hit bookmark this page and the window opens, 1st screen capture.

https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-09-24-23-47-06-d7aee0.png

Next I expand "other bookmarks" then "choose" See 2nd screen capture

https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-09-24-23-52-08-d9387a.png

When I click on "choose" see what happens in the 3rd screen capture.

https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-09-24-23-54-18-679698.png

I can choose the sub folder to save the bookmark to. BUT I now CAN'T scroll down the screen to hit the save button. Because the bookmark window doesn't have a scroll bar or a way to make the bookmark window smaller. This is frustrating. Firefox is having other issues not connected with this issue. But the overall picture is getting me to the point of dumping Firefox and going to Google Chrome.

Steve

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Hmm, what if you add the rule to suppress the screenshot and site icon section at the top of the drop-down to the beginning of your userChrome.css file. Do these rules work?

/* Hide Giant Thumbnail and Favicon */
#editBookmarkPanelImage, 
*|div#editBookmarkPanelFaviconContainer {
  display: none !important;
}

(Originally suggested here: https://support.mozilla.org/en-US/questions/1305849#answer-1353063 )

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (20)

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Hữu ích?

more options

I booted Firefox in safe mode. Bookmark problem is still there.

FredMcD said

Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Hữu ích?

more options

Check your zoom controls.

<Control> (Mac=<Command>) + (plus) enlarge - (minus) reduce 0 (zero) restore

Hữu ích?

more options

Using the mouse, grab a corner and move it around.

Hữu ích?

more options

I didn't know about the Ctrl > + and - zoom controls. But those zoom controls only control the web page. Not the bookmark window. Also I can't grab any edge of the bookmark window.

Hữu ích?

more options

Let’s do a full clean re-install;

Note: Firefox comes in three or more folders on all computers. They are;

Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user.

If you remove the Firefox folder, the user profiles would not be affected.


Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Hữu ích?

more options

You can possibly use code in userChrome.css to hide the section at the top that shows the favicon and preview image.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* BOOKMARK EDIT - Info Area - giant image */
*|div#editBookmarkPanelInfoArea {display:none !important}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

See:

Hữu ích?

more options

I did a full clean re-install. I del all traces of Firefox in steve > appdata. No change on the bookmark problem. BTW Mac doesn't apply here. My OS is Win 10 Pro 64 bit. Also what is this "#46" for?

FredMcD said

Let’s do a full clean re-install; Note: Firefox comes in three or more folders on all computers. They are; Maintenance: (Programs Folder) <Windows Only> Firefox itself: (Programs Folder) And two folders in the profile of each user on the computer for each Firefox profile for that user. If you remove the Firefox folder, the user profiles would not be affected.

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86) Note: Check Both Folders

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

Hữu ích?

more options

You can add another rule to userChrome.css to set the height of this edit this bookmark panel.


#editBookmarkPanel { height: 40em !important; }

Được chỉnh sửa bởi cor-el vào

Hữu ích?

more options

This isn't pretty, but you can force the scroll bar to appear on the entire drop-down:

panel[type="arrow"].panel-no-padding::part(arrowcontent) {
  max-height: 85vh !important;
  overflow-y: scroll !important;
  margin-right: 6px !important;
}

Hữu ích?

more options

Where do I type these lines in?

jscher2000 said

This isn't pretty, but you can force the scroll bar to appear on the entire drop-down:
panel[type="arrow"].panel-no-padding::part(arrowcontent) {
  max-height: 85vh !important;
  overflow-y: scroll !important;
  margin-right: 6px !important;
}

Hữu ích?

more options

Hi reble, that would go into a userChrome.css file as mentioned by cor-el. I can give you a more step-by-step guide.

Setting this up is a little bit involved, so please set aside 10 quiet minutes to work through it.

(For anyone who already has a userChrome.css file set up, you just need to add the rule under (A) to your file.)

(A) Select and copy the following style rule code

/* Scroll Bar on Add/Edit Bookmarks Panel */
panel[type="arrow"].panel-no-padding::part(arrowcontent) {
  max-height: 85vh !important;
  overflow-y: scroll !important;
  margin-right: 6px !important;
}


(B) Generate and download a userChrome.css file

Open the following page and paste the above rules into the editor, replacing the sample rule:

https://www.userchrome.org/download-userchrome-css.html

Then click "Generate CSS File" and save the userChrome.css file to your computer. (See first attached screenshot)

Use the downloads list on the toolbar to open the downloads folder directly to the new userChrome.css file. (See second attached screenshot)

Minimize that file browser window for later reference.

(C) Create a new chrome folder in your profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)

https://www.userchrome.org/how-create-userchrome-css.html

I have videos for both Windows and Mac in case the text is not clear.

(D) Move the userChrome.css file you downloaded in Step B into the chrome folder you created in Step C

(E) Set Firefox to look for userChrome.css at startup -- see step #6 in the above article.

The next time you exit Firefox and start it up again, it should discover that file and apply the rule.

Success?

Once you start tweaking the interface this way, you'll probably find more and more things you want to do. I suggest bookmarking the pages where you get the code for future reference because changes to Firefox may break them and it's easier to request an update if you can find the source.

Hữu ích?

more options

What does "userChrome.css" have to do with Firefox? I am not using Google Chrome. I am missing something here.

jscher2000 said

Hi reble, that would go into a userChrome.css file as mentioned by cor-el. I can give you a more step-by-step guide. Setting this up is a little bit involved, so please set aside 10 quiet minutes to work through it. (For anyone who already has a userChrome.css file set up, you just need to add the rule under (A) to your file.) (A) Select and copy the following style rule code
/* Scroll Bar on Add/Edit Bookmarks Panel */
panel[type="arrow"].panel-no-padding::part(arrowcontent) {
  max-height: 85vh !important;
  overflow-y: scroll !important;
  margin-right: 6px !important;
}


(B) Generate and download a userChrome.css file

Open the following page and paste the above rules into the editor, replacing the sample rule:

https://www.userchrome.org/download-userchrome-css.html

Then click "Generate CSS File" and save the userChrome.css file to your computer. (See first attached screenshot)

Use the downloads list on the toolbar to open the downloads folder directly to the new userChrome.css file. (See second attached screenshot)

Minimize that file browser window for later reference.

(C) Create a new chrome folder in your profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)

https://www.userchrome.org/how-create-userchrome-css.html

I have videos for both Windows and Mac in case the text is not clear.

(D) Move the userChrome.css file you downloaded in Step B into the chrome folder you created in Step C

(E) Set Firefox to look for userChrome.css at startup -- see step #6 in the above article.

The next time you exit Firefox and start it up again, it should discover that file and apply the rule.

Success?

Once you start tweaking the interface this way, you'll probably find more and more things you want to do. I suggest bookmarking the pages where you get the code for future reference because changes to Firefox may break them and it's easier to request an update if you can find the source.

Hữu ích?

more options

Hi reble, userChrome.css doesn't have anything to do with Google Chrome. It is an optional file you can create to modify Firefox's toolbar area.

("chrome" is a term Mozilla has used for the browser user interface for decades. Another company liked it so much they named a bunch of products after it.)

More info/background: https://www.userchrome.org/

Hữu ích?

more options

there is some kind of pull down page that is under the normal web page, when it opens, with this kind of coding

/* Scroll Bar on Add/Edit Bookmarks Panel */ panel[type="arrow"].panel-no-padding::part(arrowcontent) {

 max-height: 85vh !important;
 overflow-y: scroll !important;
 margin-right: 6px !important;

}

in it. I stumbled on that pull down page once. But I don't remember how to open it.

Hữu ích?

more options

reble said

there is some kind of pull down page that is under the normal web page, when it opens, with this kind of coding in it. I stumbled on that pull down page once. But I don't remember how to open it.

Hi reble, do you mean the Developer Tools? You can pop those open with Ctrl+Shift+i to look at the HTML and style rules in the page. Those panels don't relate to the toolbar area, unless something really weird is happening.

Hữu ích?

more options

OOOO k I though the lines bellow

/* Scroll Bar on Add/Edit Bookmarks Panel */ panel[type="arrow"].panel-no-padding::part(arrowcontent) {

max-height: 85vh !important;
overflow-y: scroll !important;
margin-right: 6px !important;

}

went in the Developer Tools. That just shows how little I know of the iner workings of Firefox. I have fixed 2 

way radios, tv's, 1st gen vcr's and I have done board level repair, replaced power supplys and replaced motherboards on windows based towers and some some repairs on laptop. But programing. I am barely scratching the surface.

jscher2000 said

reble said

there is some kind of pull down page that is under the normal web page, when it opens, with this kind of coding in it. I stumbled on that pull down page once. But I don't remember how to open it.

Hi reble, do you mean the Developer Tools? You can pop those open with Ctrl+Shift+i to look at the HTML and style rules in the page. Those panels don't relate to the toolbar area, unless something really weird is happening.

Được chỉnh sửa bởi reble vào

Hữu ích?

more options

The userChrome.css file is all done and the:

/* Scroll Bar on Add/Edit Bookmarks Panel */ panel[type="arrow"].panel-no-padding::part(arrowcontent) {

max-height: 85vh !important; overflow-y: scroll !important; margin-right: 6px !important;

}

is added to the file. Here come the acid test. I am going to restart Firefox and see if it works

Hữu ích?

more options

The script didn't add a scroll bar to the "bookmark this page" window. But the "bookmark this page" window is now staying within the confines of the Firefox overall window when I click on the "choose" sub menu.

Được chỉnh sửa bởi reble vào

Hữu ích?

more options

Hmm, that's strange. Setting overflow-y:scroll definitely should force a scrollbar, but I can only test on my own Firefox so perhaps I overlooked something?

Hữu ích?

  1. 1
  2. 2
  3. 3
Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.