Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox keeps re-adding ads to my new-tab page

  • 7 trả lời
  • 1 gặp vấn đề này
  • 28 lượt xem
  • Trả lời mới nhất được viết bởi firefox971

more options

I keep disabling the ads from my new-tab page, but firefox keeps re-enabling them. How do I permanently disable them?

Giải pháp được chọn

Articles in the Recommended by Pocket section aren't ads, other than "Sponsored Stories", they are stories popular with Pocket users. Anyway, the preference for those is named

browser.newtabpage.activity-stream.feeds.section.topstories

Does it get switched between true and false when you check and uncheck the box?

The corresponding Sync preference is named:

services.sync.prefs.sync.browser.newtabpage.activity-stream.feeds.section.topstories

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (7)

more options

Do you mean you go to the Preferences page and uncheck the box for a category but it later gets re-checked: Hide or display content in New Tab.

Have you noticed any pattern to when they return? For example, when quitting/restarting Firefox, when shutting down/restarting the system, after a certain time interval, at random?

Do you use Sync?

Hữu ích?

more options

Yup, that's exactly it. I have not noticed any pattern that I can say for certain. It seems like maybe it's sometimes after a reboot, but it's definitely not consistently after a reboot.

Yes, I use Sync

Hữu ích?

more options

Which section?

Let's say for example that you are turning off Snippets.

Have you used about:config? See: Configuration Editor for Firefox

In about:config, the corresponding preference is:

browser.newtabpage.activity-stream.feeds.snippets

The preference for whether to sync that preference is called:

services.sync.prefs.sync.browser.newtabpage.activity-stream.feeds.snippets

So you can individually disable Sync on that preference to rule out Sync as the source of changes. Double-click the preference to flip it from true to false.

Does that make sense?

At least I think that's how it works, I don't Sync any preferences.

Hữu ích?

more options

The returning section is the 'recommended by pocket' ads. I've already disabled them in preferences and about:config. I hadn't seen those sync settings in about:config, so I disabled it there and will see if they return. Thank you

But I don't know why syncing would re-enable them as both of my computers have them disabled. I'm also confused as to why I would need to go to about:config anyway to disable something like that, when I've already disabled it in the UI.

Hữu ích?

more options

Giải pháp được chọn

Articles in the Recommended by Pocket section aren't ads, other than "Sponsored Stories", they are stories popular with Pocket users. Anyway, the preference for those is named

browser.newtabpage.activity-stream.feeds.section.topstories

Does it get switched between true and false when you check and uncheck the box?

The corresponding Sync preference is named:

services.sync.prefs.sync.browser.newtabpage.activity-stream.feeds.section.topstories

Hữu ích?

more options

You can put lipstick on a pig and call it a woman all you want, but it's still a pig. I find it sad and disappointing that the Mozilla I grew to love and support years ago has these ads as a part of Firefox in the first place.

Yes,browser.newtabpage.activity-stream.feeds.section.topstories does change in about:config when I toggle that button in the options. I've disabled the sync preference for it in case that has something to do with it turning back on.

Hopefully that keeps these ads away Thanks

Hữu ích?

more options

This seems to have worked as the ads haven't shown up again. Thanks

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.