Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Something in my main Firefox profile is broken, and it's causing graphical issues on multiple websites.

  • 5 trả lời
  • 1 gặp vấn đề này
  • 32 lượt xem
  • Trả lời mới nhất được viết bởi TidusWulf

more options

One website, Discord, has a broken Favicon in the tab. A photo is attached. I read another support thread that said to clear the favicon files from the user profile by opening the Directory from About:Profiles. I did this. It did not fix the issue. What is more strange is that the home page for Discord doesn't have this problem. It's only when I log in and go to the list of channels available that this happens.

But, I think whatever bug I'm experiencing is not solely a favicon bug, because I also have a weird graphical issue when visiting this website: https://james.darpinian.com/satellites/ One icon should say "You" and any traveling satellites should be labeled with the satellite's name. I've tried clearing any browser cache/data related to that website and it's not fixed. I've attached a screenshot from Microsoft Edge on the same computer showing how it's meant to look.

Just now, I went to the about:profiles and opened the hidden "default profile" in a new window. Going to the Discord website or the satellite does NOT reproduce these graphical errors. How can I sort of "clean up" my primary profile to fix these things?

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

TidusWulf said

I do know that I have a privacy setting flagged that reduces browser tracking, and one of its side effects is that Firefox never opens maximized by default and the clock in firefox isn't the same time zone as my PC.

Aha! If you want to keep using privacy.resistFingerprinting, you could either adopt the strategy of:

(A) Spotting this problem and granting a site-specific permission, or (B) Not fuzzing the canvas.

For Option A:

The easiest way to set a custom permission for a site is to use the Page Info dialog. While you are on the relevant page, you can call that up using either:

  • Ctrl+i (for Mac, Command+i)
  • right-click a blank area of the page > View Page Info
  • (menu bar) Tools > Page Info

When the dialog comes up, click the Permission icon at the top to show that panel.

Scroll down to "Extract Canvas Data" and uncheck the "Use default" box, and then select Allow to stop the blurring on that site.

Note: This permission is hidden if you do not have privacy.resistFingerprinting set to true.

For Option B:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste resist and pause while the list is filtered

(3) Double-click the privacy.resistFingerprinting.randomDataOnCanvasExtract preference to switch the value from true to false

This should take effect when you reload the page.

More info on about:config: Configuration Editor for Firefox.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (5)

more options

These are both odd cases.

The site icon typically is the same for every page of a site, but sometimes a site adds a badge showing a little status badge, such as the number of unread messages or new notifications. Does Discord do that?

If so, then perhaps both of these cases point to a problem rendering text into a graphic. On the satellite case, it's an HTML canvas element. Do you know whether any of your add-ons affect rendering of HTML canvases, or whether you have changed any settings that might be related to canvases?

Hữu ích?

more options

I temporarily disabled all add-ons. Both problems persist. I'm not sure if any of my add-ons affect HTML canvases. It is possible that I changed settings at some point, but this has been a problem I've been ignoring for many months now, so I can't say with any certainty when it started or if it started when I made a certain change. I do know that I have a privacy setting flagged that reduces browser tracking, and one of its side effects is that Firefox never opens maximized by default and the clock in firefox isn't the same time zone as my PC. It's likely I have other privacy settings changed as well possibly. But I didn't go too crazy because a lot of the aggressive stuff was breaking websites badly.

Hữu ích?

more options

Sorry. To answer your Discord Question, I'm afraid I'm not sure. It's not something I use regularly. And it's been so long since it worked that I just don't know if it shows a counter.

Hữu ích?

more options

Giải pháp được chọn

TidusWulf said

I do know that I have a privacy setting flagged that reduces browser tracking, and one of its side effects is that Firefox never opens maximized by default and the clock in firefox isn't the same time zone as my PC.

Aha! If you want to keep using privacy.resistFingerprinting, you could either adopt the strategy of:

(A) Spotting this problem and granting a site-specific permission, or (B) Not fuzzing the canvas.

For Option A:

The easiest way to set a custom permission for a site is to use the Page Info dialog. While you are on the relevant page, you can call that up using either:

  • Ctrl+i (for Mac, Command+i)
  • right-click a blank area of the page > View Page Info
  • (menu bar) Tools > Page Info

When the dialog comes up, click the Permission icon at the top to show that panel.

Scroll down to "Extract Canvas Data" and uncheck the "Use default" box, and then select Allow to stop the blurring on that site.

Note: This permission is hidden if you do not have privacy.resistFingerprinting set to true.

For Option B:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste resist and pause while the list is filtered

(3) Double-click the privacy.resistFingerprinting.randomDataOnCanvasExtract preference to switch the value from true to false

This should take effect when you reload the page.

More info on about:config: Configuration Editor for Firefox.

Hữu ích?

more options

Thank you. I went with Option A and both problems are fixed.

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.