Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox 80.0 not loading on puppy linux 6.3.2.

  • 8 trả lời
  • 1 gặp vấn đề này
  • 65 lượt xem
  • Trả lời mới nhất được viết bởi Rosscoe68

more options

Will not load. Running from console produces the included screenshot text then exits on a channel error. I'll submit the crash report again when I figure out again how to do that. (Hint- assistance welcome) Ross Smith

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Rosscoe68 said

Checking in again after determining system requirements. Am using Slacko Puppy Linux 6.3.2. 32-bit for universality on my systems. Am currently running Firefox 79.0 32-bit and am using it to write this entry. Here is a list of what I have as minimal system requirements; GTK3-3.8.2.

I think you mean GTK 3.18.2 as 3.8.2 would not not be high enough.

The requirements for Linux as not changed since 78.0 https://www.mozilla.org/firefox/78.0/system-requirements/ https://www.mozilla.org/firefox/79.0/system-requirements/ https://www.mozilla.org/firefox/80.0/system-requirements/

I no longer have a 32-bit Linux system in use for five years now so I can try the 32-bit version myself.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (8)

more options

Your hardware might be too old to run current Firefox builds properly.

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Hữu ích?

more options

Are you using Firefox from www.mozilla.org/firefox/all/ ? or a package build from distro ?

Firefox from Mozilla since 78.0 has a new system requirements https://www.mozilla.org/firefox/78.0/releasenotes/

The minimal system requirements on Linux have been updated. Firefox now needs GNU libc 2.17, libstdc++ 4.8.1 and GTK+ 3.14 or newer versions.

Hữu ích?

more options

Sorry, should have included that it failed after updating from version 79.0.

I have been using Firefox from Mozilla, not from distro. This is affecting 3 different systems all running Linux. I doubt it is hardware related since one of the oldest of them is dual-boot with Win7 pro and it updated the win version successfully. All were running Firefox 79.0 perfectly. I'm also using current Thunderbird version 68.12 and it updated successfully on all my systems.

James, did the minimal system requirements you listed change between ver 79.0 and 80.0? Thanks for supplying that. I will check and report back.

Ross

Hữu ích?

more options

Checking back in. Here's what I'm using with regards to Firefox minimal requirements. I am still running Slacko Puppy 6.3.2., 32-bit, (previous 6.3.0. mention was wrong, btw) for universality on all systems. That is likely going to change to 64-bit soon.

Here is what Puppy is running at present on all systems;

GTK3-3.8.2. gnulibc 2.1.7. libstdc++.so.6.0.18 X.Org version 1.14.3

It would appear that I meet minimal system requirements. As mentioned previously Puppy runs version 79.0 perfectly, (I'm using it to write this). Since Firefox doesn't load far enough to give me access to the crash reporter I can only rely on the console info, which seems to be a problem with the libxul.so library.

I have tried downloading the entire 71mb 32-bit Linux version from Mozilla and it fails in exactly the same way.

Hữu ích?

more options

Checking in again after determining system requirements.

Am using Slacko Puppy Linux 6.3.2. 32-bit for universality on my systems. Am currently running Firefox 79.0 32-bit and am using it to write this entry. Here is a list of what I have as minimal system requirements;

GTK3-3.8.2. gnulibc 2.17 libstdc++.so.6.0.18 X.Org 1.14.3

It appears I meet minimal requirements. Since version 80 will not load I can only rely on info supplied from the console execution list and that shows some undefined symbol issue with libxul.so causing an exit.

Sorry I can't provide a crash report. Any help here would be appreciated.

Ross

Hữu ích?

more options

Giải pháp được chọn

Rosscoe68 said

Checking in again after determining system requirements. Am using Slacko Puppy Linux 6.3.2. 32-bit for universality on my systems. Am currently running Firefox 79.0 32-bit and am using it to write this entry. Here is a list of what I have as minimal system requirements; GTK3-3.8.2.

I think you mean GTK 3.18.2 as 3.8.2 would not not be high enough.

The requirements for Linux as not changed since 78.0 https://www.mozilla.org/firefox/78.0/system-requirements/ https://www.mozilla.org/firefox/79.0/system-requirements/ https://www.mozilla.org/firefox/80.0/system-requirements/

I no longer have a 32-bit Linux system in use for five years now so I can try the 32-bit version myself.

Hữu ích?

more options

There are several blocked items in the featureLog section in your troubleshooting information among this one:

{name: OMTP, description: Off Main Thread Painting, status: broken, log: [{type: default, status: available}, {type: runtime, status: broken, message: OMTP is not supported on 32-bit with <= 2 cores}]}

Hữu ích?

more options

My face is red and also shows my declining vision. I have thought the minimal requirements for GTK were 3.1.4. There was no error in what I entered. Puppy runs version 3.8.2. and it most likely explains why I can't run FF 80, although how it allows me to run 79.0 has me scratching my head in wonder.

Thanks for your prompt replies, James and Cor-el. Looks like I'm going to be busy in the near future. I'll mark this conversation as solved.

Ross

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.