Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Cannot play local swf files [linux]

  • 1 trả lời
  • 1 gặp vấn đề này
  • 9 lượt xem
  • Trả lời mới nhất được viết bởi Kawaii Amber

more options

I made a new profile and was able to re-create the same bug in safe mode just to be sure. Anytime I try to open a swf file, firefox will not open it but instead ask what I should do with the file, over and over again. I have properly installed flash in the $MOZ_PLUGIN_PATH directory that firefox looks for; if I go to the plugins section, it shows adobe flash. I also have the ability to play flash files on websites, just not locally. On the profile I'm using to reproduce the error, the http_https_only tag in about:config is set to 'false', so [[this|https://support.mozilla.org/en-US/questions/1172126]] is irrelevant. I made sure that firefox is indeed what is set to open these types of files via the xdg specifications that firefox searches for when looking what to open a file with via xdg-mime (firefox uses xdg-open on the linux version to see what to open with): xdg-mime default firefox.desktop application/x-shockwave-flash In $HOME/.config/mimeapps.list, it is properly listed in the line applications/x-shockwave-flash=firefox.desktop Firefox does have a .desktop file setup in /usr/share/applications, and xdg-mime does recognize firefox as the app to open swf files. I am able to open other types of files locally such as videos. Going to about:preferences and setting firefox to open swf files makes an infinite loop of firefox opening new tabs that must be then terminated. I'm not sure if an update broke firefox, as I was previously able to open local swf files. Thanks.

Đính kèm ảnh chụp màn hình

Tất cả các câu trả lời (1)

more options

UPDATE: Moving the libflashplayer.so to $HOME/.mozilla/plugins (the second location $MOZ_PLUGIN_PATH reads for) also does not fix the issue. (Ignore the typo with applications instead of application in screenshots, that doesn't change the problem.)

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.