Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox completely stops canvas rendering after switching back from a tab

  • 2 trả lời
  • 1 gặp vấn đề này
  • 1 lượt xem
  • Trả lời mới nhất được viết bởi Sourav

more options

I have been facing this problem from some of the recent versions where:

  1. I open a tab with an HTML 5 canvas [please see note 1 below] with some drawing animation or even online games
  2. I switch to another tab, wait for a couple of seconds there.
  3. Come back to the previous tab (point 1 tab) and see the beauty of frozen canvas (completely stopped rendering)

[note 1] For the test, I also have an open source app that has the canvas (no ads): http://jmblr.rf.gd/?i=1 ... </div>

Here you click on a word, then click on the organized words, that will open a background tab in duckduckgo. Then come back to the tab of jmblr.rf.gd, you will see it. If you can't see, try opening a couple of more tabs, maybe wait 2 seconds for each. Won't take long for the freezing experience.

Now this doesn't only happen with my apps, but also with other apps, and games (well this feels bad to write a site full of crappy ads, but I played subway surfer on www.poki.com and the game froze in a similar way when I switched to another tab).



Recently I was playing subway surfers online, and then switched tab, then came back and saw the game is frozen. It's happening for a month or two now...

I have tried different sandbox levels from about:config (because I previously set "security.sandbox.content.level", and "security.sandbox.socket.process.level" to 0), tried the default one, nope that's not a problem here.

What's going on?

Được chỉnh sửa bởi Sourav vào

Tất cả các câu trả lời (2)

more options

Firefox will detect if your computer's memory is running low, which is defined as lower than 400MB, and suspend unused tabs that you haven't used or looked at in a while.
The new tab unload feature is controlled on the about:config page with a preference that you can set to false to disable this feature.
Keep in mind that this makes you vulnerable to low memory issues.

  • browser.tabs.unloadOnLowMemory = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


more options

cor-el said

Firefox will detect if your computer's memory is running low, which is defined as lower than 400MB, and suspend unused tabs that you haven't used or looked at in a while.
The new tab unload feature is controlled on the about:config page with a preference that you can set to false to disable this feature.

Hi, I already have:

    browser.tabs.remote.warmup.unloadDelayMs    2000
    browser.tabs.unloadOnLowMemory    false
    dom.beforeunload_timeout_ms    1000
    dom.disable_beforeunload    false
    dom.ipc.plugins.unloadTimeoutSecs    30
    dom.require_user_interaction_for_beforeunload    true

However, I don't know how firefox detects memory usage (but I guess from
/proc/meminfo
or something like that), my system has 4 GB RAM, most of the time, I use all of 4 GB, and I do have a 4 GB ZRAM, which is then used by other applications.

But you know what? I just tested after closing my apps, I have ~ 50% available memory. But unfortunately, the same thing is happening.

As I said in the question, this problem was not there, but I think appeared recently after one or two upgrades.

Oh and I am using Arch Linux, but this info is irrelevant because Firefox is downloaded from the Mozilla and not using the Firefox from Arch Linux repository.

Được chỉnh sửa bởi Sourav vào