Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Files containing Japanese characters are garbled in Firefox 68.6.0esr

  • 3 trả lời
  • 1 gặp vấn đề này
  • 25 lượt xem
  • Trả lời mới nhất được viết bởi HAYASHI Tomoko

more options

After upgrading to Firefox 68.6.0esr, when we open a Japanese file with [File]->[Open], it becomes garbled and unreadable. Before upgrading, we could read the Japanese file. This file is a plain text file and the character code is ISO-2022-JP. The character code is not specified in the file. I tried to change the character code with Text Encoding menu of Firefox, but the menu is grayed out and we cannot select it. It seems that files with character codes UTF and EUC can be displayed without problems. Is there a way to correctly display a Japanese file in which no character code is specified?



Tất cả các câu trả lời (3)

more options



Do you possibly have disabled multi-process in Firefox by using the MOZ_FORCE_DISABLE_E10S=1 environment variable?

   Bug 1638652 - Content-Encoding not honored when e10s is turned off via 

browser.tabs.remote.autostart=false or MOZ_FORCE_DISABLE_E10S=1

(please do not comment in bug reports


i hope resolved your problem then relpy back to me

thank you!

more options

What kind of files are that ?

An internet search suggest that this encoding is mainly used for emails.

Note that current is Firefox 68.10.0 ESR and the first Firefox 78.0.1 ESR version is available for testing. Firefox 68.10.0 ESR (you can find 78 ESR in the version elector drop-down list):

more options

Thank you for your reply.

Yes, this file is a mail file saved in MH format.

I tried it on Firefox for Windows, but I still can't read garbled characters on the 68.10.0 ESR version, but I didn't see this problem on the 78ESR.

Unfortunately I'm using Firefox bundled with Oracle Solaris 11.4, so a new version will not be available unless Oracle upgrades Firefox.

I am looking for a way to fix this issue with 68esr.