Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Autoplay not always blocked

  • 3 trả lời
  • 2 gặp vấn đề này
  • 351 lượt xem
  • Trả lời mới nhất được viết bởi ascaris

more options

Firefox 78 sometimes fails to block autoplay, e.g. scrolling the front page of reddit.com or a subreddit will intermittently show videos playing.

This worked in 77. Some about:config entries I'd swear were set in 77 have vanished; I tried adding them manually, but the autoplay blocking is still hit and miss.

Also, not sure if Troubleshooting Information uploaded successfully or the page broke (see screenshot).

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Setting media.autoplay.blocking_policy to 2 seems to work, but I shouldn't have to do this manually just because Firefox updated.

I'd still like to know if the Troubleshooting Information field in the submission form actually did what it was supposed to.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (3)

more options

Giải pháp được chọn

Setting media.autoplay.blocking_policy to 2 seems to work, but I shouldn't have to do this manually just because Firefox updated.

I'd still like to know if the Troubleshooting Information field in the submission form actually did what it was supposed to.

more options

There was no troubleshooting information send as that would appear if you click "More system details" in the side menu next to your question, so something went wrong.

See also:

more options

Edit: I had previously said autoplay blocking from the Preferences | Permissions for autoplay worked on one of my three PCs. Now it's not working on any of them, so my guess is that it's an intermittent issue as the OP wrote, and I just thought it was tied to the machines.

I use FF 83 on Linux, and as of this moment, it ignores the UI under Permissions that is set to Block audio and video (pref media.autoplay.default set to 5) on all of my machines.

I tried starting in safe mode and going to a video site, and this time, it blocked as it was supposed to. After I restarted Firefox, though, and disabled all the addons manually, one by one, it did not block autoplay. It would appear to be a pref that gets temporarily reset in safe mode.

After searching the web about the issue, I found this page, and I set the media.autoplay.blocking_policy pref to 2 as suggested, and indeed, it worked.

Được chỉnh sửa bởi ascaris vào