Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Microsoft Edge is blocking Firefox

  • 5 trả lời
  • 1 gặp vấn đề này
  • 77 lượt xem
  • Trả lời mới nhất được viết bởi Joel

more options

Hi Firefox community. I badly need your assistance.

I just installed Microsoft Edge (on Windows 10) to see what features it has. I'm a longtime Firefox user and a fan of the product.

Immediately after installing Edge, Firefox stopped working. I checked my settings and Firefox is still my default browser. I'm able to run Firefox but I am not able to access any websites. This is true whether I click a bookmark or I manually type a URL.

I have a strong internet connection and I'm able to access websites using Edge.

Is Microsoft literally trying to steal the Firefox customer base by blocking the use of Firefox after Edge is installed? I went to my settings menu to see whether I could uninstall Edge but the uninstall button is grayed out. I'm also worried that if I did uninstall Edge, I wouldn't have any browser at all.

What's the solution here? I've tried reinstalling Firefox but that didn't solve the problem.

Please help if you can. Thanks very much!

Tất cả các câu trả lời (5)

more options

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network.

[56+] Type about:preferences#general<enter> in the address bar. Look for Network.
+++++++++++++++++++++
Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first try No Proxy. If there is a problem, then try System Proxy.


Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

Hữu ích?

more options

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Hữu ích?

more options

FredMcD said

Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select Network. [56+] Type about:preferences#general<enter> in the address bar. Look for Network.
+++++++++++++++++++++
Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first try No Proxy. If there is a problem, then try System Proxy.

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

Thanks Fred. This gave me lots of things to try but it didn't help me gain access using Firefox.

My Network setting was set to No Proxy. I tried switching it to System Proxy but it didn't resolve the issue. I also tried switching the setting back to No Proxy but still no go.

Next, I followed the directions and ran that little enum process. It said I was using Windows Firewall. I was able to remove Firefox from the list of trusted apps and then re-add it. Still no go.

Any other ideas? I greatly appreciate your help.

Hữu ích?

more options

cor-el said

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Thanks cor-el. I tried to boot into safe mode with networking using a variety of methods. No matter what I tried, I was able to get into Safe Mode but, even though I chose the "with networking" option, I had no internet access when I booted into Safe Mode.

Any other ideas? Thanks for your help!

Hữu ích?

more options

I've finally made "some" progress with this problem.

I turned off all my Firefox extensions and then re-activated them one at a time. The extension that was causing the problem was NoScript. I made sure I have the latest version but, when NoScript is on, I still can't reach any websites in Firefox. With NoScript off, I can reach "most" websites (see below). I don't have this problem using Edge. Does anyone know how to fix this? By the way, I'm running Firefox 77.0.1 (64-bit) on Windows 10.

Also, I now have a new problem that may or may not be related. I am not able to reach any reddit.com pages or any google groups pages. When I click a link to go to either of these social networking sites, absolutely nothing happens. If the tab I'm using is already on a web page, it just sits there when I try to access either reddit or a google groups page.

Ideas would be appreciated ...

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.