Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Unable to upload files using Firefox Ubuntu 18.04

  • 1 trả lời
  • 1 gặp vấn đề này
  • 10 lượt xem
  • Trả lời mới nhất được viết bởi Mick

more options

Hello there,

I'm writing to report a problem that I had with Firefox. I'm using Ubuntu 18.04.4 LTS, GNOME 3.28.2 with a 64-bit OS.

Recently, I noticed that I could not save PDFs from the internet to my hard drive when I was using Firefox. Normally, if I had opened a PDF in Firefox, I could press 'Ctrl + S' on my keyboard and a save dialog window would appear. Now however, the save dialog window would not appear. No error messages appeared, so I have no screenshots to show. The only thing I could do to save the PDF was to click on the 'Download' icon in Firefox's PDF reader. Right-clicking on links to PDFs and selecting 'Save As' would yield the same result: no save dialog window, nothing.

I thought that the problem might be because my version of Firefox was not up to date, so I ran 'sudo apt-get update' and 'sudo apt-get install firefox' in the terminal. I also updated the flash plugin.

Afterwards, I noticed that I could not upload files from my hard drive as an attachment for e-mails. I tried this on different websites and had the same problem. I tried the solutions described on the following pages, but none of them worked. (1) https://support.mozilla.org/en-US/questions/1039987 (2) https://support.mozilla.org/en-US/kb/cant-download-or-save-files (3) https://unix.stackexchange.com/questions/471168/permission-denied-when-browsing-for-files-using-ubuntu-18-04

While trying to solve the problem, I opened the 'Ubuntu Software' program, clicked on the 'Installed' tab, and noticed that I had two versions of Firefox installed on my computer: "Firefox" (Version: 77.0.1-1, source: Snap Store) and "Firefox Web Browser" (Version: 77.0.1+build-1-0ubuntu0.18.04.1, Source: ubuntu-bionic-updates-main, updated 11.06.2020).

I first uninstalled the 77.0.1+build-1-0ubuntu0.18.04.1 version from ubuntu-bionic-updates-main, and kept the 77.0.1-1 version from the Snap Store. The problem remained.

Then, I uninstalled the 77.0.1-1 version from the Snap Store and reinstalled the 77.0.1+build-1-0ubuntu0.18.04.1 version from ubuntu-bionic-updates-main. This resolved the problem. I can now save PDF files by pressing 'Ctrl+S' on my keyboard and i can upload files.

I'm reporting this because I think other people might encounter the same problem as I did. Also, if it is possible, I think it would be better to coordinate with the people who maintain the Ubuntu software packages so that only one version of Firefox appears in the 'Ubuntu Software' program, instead of two.

Được chỉnh sửa bởi HCL vào

Tất cả các câu trả lời (1)

more options

Hi HCL, Great that you managed to fix it and came back to edit your question so other people looking for a similar issue may be able to use a slution similar to yours.

Could you mark your question as solved since you found the solution?

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.