Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesn't display my local HTML web site properly?

  • 2 trả lời
  • 1 gặp vấn đề này
  • 29 lượt xem
  • Trả lời mới nhất được viết bởi Ibrahim

more options

Hello, I saved a page as html (complete) but when I tried to display html in firefox look like in attached. I open the file with Dreamweaver. It display properly but file size is very high. For that I want to display with firefox. Can you help me?

Đính kèm ảnh chụp màn hình

Giải pháp được chọn

Hi Ibrahim, my first impression is that your stylesheets are not being applied. Are you able to tell whether Firefox loading them and, if not, why not? For example, in the Page Inspector, can you see the missing rules in the right side as you inspect various elements?

https://developer.mozilla.org/docs/Tools/Page_Inspector

Please check Firefox's Web Console for any relevant error messages or warnings related to those stylesheets.

https://developer.mozilla.org/docs/Tools/Web_Console


Firefox does have certain security restrictions on scripts in local pages. To test whether those are creating this issue, you can temporarily turn off the following protection:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste unique and pause while the list is filtered

(3) Double-click the privacy.file_unique_origin preference to switch the value from true to false

If you reload the page, does more/different content load?

(More info on about:config: Configuration Editor for Firefox.)

To reduce the risk of data collection attacks by scripts in pages you save to disk, please save untrusted pages in their own individual folders away from any downloaded files that may contain valuable data.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (2)

more options

Giải pháp được chọn

Hi Ibrahim, my first impression is that your stylesheets are not being applied. Are you able to tell whether Firefox loading them and, if not, why not? For example, in the Page Inspector, can you see the missing rules in the right side as you inspect various elements?

https://developer.mozilla.org/docs/Tools/Page_Inspector

Please check Firefox's Web Console for any relevant error messages or warnings related to those stylesheets.

https://developer.mozilla.org/docs/Tools/Web_Console


Firefox does have certain security restrictions on scripts in local pages. To test whether those are creating this issue, you can temporarily turn off the following protection:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste unique and pause while the list is filtered

(3) Double-click the privacy.file_unique_origin preference to switch the value from true to false

If you reload the page, does more/different content load?

(More info on about:config: Configuration Editor for Firefox.)

To reduce the risk of data collection attacks by scripts in pages you save to disk, please save untrusted pages in their own individual folders away from any downloaded files that may contain valuable data.

Hữu ích?

more options

jscher2000 said

Hi Ibrahim, my first impression is that your stylesheets are not being applied. Are you able to tell whether Firefox loading them and, if not, why not? For example, in the Page Inspector, can you see the missing rules in the right side as you inspect various elements? https://developer.mozilla.org/docs/Tools/Page_Inspector Please check Firefox's Web Console for any relevant error messages or warnings related to those stylesheets. https://developer.mozilla.org/docs/Tools/Web_Console

Firefox does have certain security restrictions on scripts in local pages. To test whether those are creating this issue, you can temporarily turn off the following protection:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste unique and pause while the list is filtered

(3) Double-click the privacy.file_unique_origin preference to switch the value from true to false

If you reload the page, does more/different content load?

(More info on about:config: Configuration Editor for Firefox.)

To reduce the risk of data collection attacks by scripts in pages you save to disk, please save untrusted pages in their own individual folders away from any downloaded files that may contain valuable data.

Thank you :) Changing value solved my issue :)

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.