Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

img src url not resolving when it is a GET request to a jsp page

  • 2 trả lời
  • 1 gặp vấn đề này
  • 2 lượt xem
  • Trả lời mới nhất được viết bởi Daniel Spencer

more options

I think this is a bug, but thought I'd ask here first.

On FireFox 76.0.1, Windows 10, 64 bit

This is not resolving (names changed for privacy)

none

The URL resolves correctly when used alone. Clicking View Image on the browser right mouse menu on the alt ('none') link also resolves correctly. According to the dev console Network tab, it's not even trying to access the specified URL, and hovering over it on the Inspector tab reports "Cannot load image"

The page containing that image definition works correctly in Chrome, Edge beta, and Opera.

Thanks! Dan

Giải pháp được chọn

Okay, it appears to have something to do with the URL being an alias of something else. If I put in the explicit IP address target it works. Not exactly intuitive, but good enough....

Đọc câu trả lời này trong ngữ cảnh 👍 0

All Replies (2)

more options

Sorry, it appears to have swallowed my img definition. The 'none' above is from this (brackets removed): img alt="none" src="http://somewhere.com/GetUserImage.jsp?user=someone"

Or right mouse on 'none' above and Inspect Element

Helpful?

more options

Giải pháp được chọn

Okay, it appears to have something to do with the URL being an alias of something else. If I put in the explicit IP address target it works. Not exactly intuitive, but good enough....

Helpful?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.