Tìm kiếm hỗ trợ

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't access Wikipedia (and some other sites): “Secure Connection Failed”

  • 4 trả lời
  • 1 gặp vấn đề này
  • 73 lượt xem
  • Trả lời mới nhất được viết bởi El Buga

more options

Hello, everyone. My Firefox (v76.0.1, Windows 10 Pro 1909) can't access the English Wikipedia (en.wikipedia.org) and some other sites I need to work with. This started happening suddenly Tuesday night.

This is the error (in English, since my Firefox is in Brazilian Portuguese):

Secure Connection Failed

An error occurred during a connection to en.wikipedia.org. PR_END_OF_FILE_ERROR

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.

Please contact the website owners to inform them of this problem.

upload.wikimedia.org gives me the same error. The bizarre thing is that Wikipedias in other languages seem to work normally. Other browsers work fine.

Searching it online, it doesn't seem to be a common problem, and it just started happening by itself. I don't remember installing anything on this PC that day. My only antivirus is Windows Defender. I don't use any VPNs.

Tried all solutions I could find on Google. So far I did:

  • Ctrl + F5
  • Edited the hosts file
  • Deleted cert8.db
  • Changed network proxy settings to No proxy and Automatically detect proxy configuration (was in Use system settings)
  • Toggled DNS over HTTPS
  • Went in about:config and toggled network.dns.disableIPv6
  • Started Firefox in Safe Mode
  • Backed up the profile folder and just let Firefox create a new one
  • Rebooted my router

None of that worked.

I work with site builder platforms and since yesterday the error is starting to creep up in those servers, too.

Any ideas? I just noticed that Wikipedia search is gone from the list of opensearch engines also… This is getting increasingly bizarre…

Giải pháp được chọn

Welp, seems like I found the problem. Some days ago, before the problem started manifesting itself, I installed a brazilian software (Legendas) to automatically download subtitles to video. It malfunctioned after some uses, so I planned to uninstall it, and never did.

Cut to today, I was just taking a long last look at the Task Manager and found that it was 'still' running in background. And somehow force-closing it made the Firefox problem suddenly vanish, even if it's a completely unrelated software. Already uninstalled it, good riddance.

Thanks, and sorry to take your time: in the end it was something unrelated at all. All that matters is that my workflow is saved!

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (4)

more options

In your Reddit thread, I speculated that you have a "man in the middle" and suggested this test:

You can disable Firefox from using TLS 1.3 (the most secure protocol, used by Wikipedia) as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste TLS and pause while the list is filtered

(3) Double-click the security.tls.version.max preference to display an editing field, and change the value to 3 then press Enter or click the blue check mark button to save the change.

With a value of 3, Firefox will not try any protocols higher than TLS 1.2

Any difference?

More info on about:config: Configuration Editor for Firefox.

Hữu ích?

more options

Note that current Firefox releases use cert9.db and no longer use cert8.db.

Are you using a proxy or VPN ? You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Hữu ích?

more options

jscher2000, I replied there before seeing here, sorry.

So, I'm posting here also: After trying to tinker with the TLS versions (and being unsuccessful), I rebooted my modem and updated the network card drivers, to no avail.

cor-el, no proxies or VPNs. Firefox was set to match the system's configuration, I changed it to No proxy and the problem persists.

Do you think deleting cert9.db might solve this problem?

Được chỉnh sửa bởi El Buga vào

Hữu ích?

more options

Giải pháp được chọn

Welp, seems like I found the problem. Some days ago, before the problem started manifesting itself, I installed a brazilian software (Legendas) to automatically download subtitles to video. It malfunctioned after some uses, so I planned to uninstall it, and never did.

Cut to today, I was just taking a long last look at the Task Manager and found that it was 'still' running in background. And somehow force-closing it made the Firefox problem suddenly vanish, even if it's a completely unrelated software. Already uninstalled it, good riddance.

Thanks, and sorry to take your time: in the end it was something unrelated at all. All that matters is that my workflow is saved!

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.