Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox 76 does not save changes to about:config

  • 5 trả lời
  • 1 gặp vấn đề này
  • 4 lượt xem
  • Trả lời mới nhất được viết bởi Scribe

more options

One of the biggest problems with Firefox is that it is a resource hog. The cache is set to a 1 GB (1048576 KB) in about:config. There are multiple suggestions for resolving this in Mozilla support. However, none of them work. Any changes made, disappear the moment Firefox is closed. Does anyone have a solution that is relevant to Firefox 76.

One of the biggest problems with Firefox is that it is a resource hog. The cache is set to a 1 GB (1048576 KB) in about:config. There are multiple suggestions for resolving this in Mozilla support. However, none of them work. Any changes made, disappear the moment Firefox is closed. Does anyone have a solution that is relevant to Firefox 76.

Tất cả các câu trả lời (5)

more options

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

Hi, what is it you want to do; reduce the cache size perhaps? If you want to reduce it to, let's say, as an example, 150MB; first clear the cache: 3-bar menu > Options > Privacy & Security > Cookies and Site Data > Clear Data > (deselect Cookies and Site Data) > Clear (may take several minutes). Now type about:config into the address bar, press Enter, accept the warning, click Show All, then scroll down the alphabetical list to browser.cache.disk.smart_size.enabled and click the Toggle button on the right-hand side to change it to False then restart Firefox. Now look for browser.cache.disk.capacity (which has a default of 1048576), then click the edit button on the right, and enter 150000 before restarting Firefox again. The cache (excluding cookies) should now not exceed about 150MB.

Note: If you don't restart Firefox exactly as above the change will not stick.

more options

I appreciate your effort. However, the advice given is (mostly) the same as others. And this solution does not work. BTW, you did not actually describe the method by which you restart. I have tried all the following...

  • Close and restart as normal
  • Force close and restart via task manager
  • Close and restart via 3 Bars>Help
  • Close and restart using the about:RestartRequired page

I have tried multiple times to do everything you and others have described, including all the steps Mozilla support describes. (Fully clearing the cache, sign out/in, resetting Firefox, uninstall/reinstall and so on.) No matter how I restart, the cache will always default to 1048576.

more options

P.S. In Reply to FredMcD... I no longer have anything like that on my system. Though I had considered that back when I had Norton 360. But I have removed Norton and all attempts to resolve this have been a fail.

more options

I don't know why that doesn't work for you. I've done it on two old Win7 PCs which have slow processors with limited memory, and it noticeably speeds up the loading time.

It's been working for maybe a year, and still works on Fx76.

I restart Fx from, 3-bar menu > Exit.

Is this the only about:config that won't stick, or does it work if you change a different entry? If other entries won't stick, FredMcD's answer may be relevant - perhaps some previous, even though uninstalled software has left something behind which is still interfering.

You can check your cache size by going to about:cache in the address bar.