Tìm kiếm hỗ trợ

Cảnh giác với các cuộc tấn công lừa đảo: Mozilla sẽ không bao giờ yêu cầu bạn gọi một số hoặc truy cập trang web không phải của Mozilla. Hãy bỏ qua các yêu cầu như vậy.

Learn More

Advanced: Firefox is getting the wrong ip address for image loaded

  • 10 trả lời
  • 1 gặp vấn đề này
  • 29 lượt xem
  • Trả lời mới nhất được viết bởi blokecom

more options

Occassionally, but reproducable enough Firefox gets the wrong ip address for images that are loaded. It happens in firefox for mac/linux/windows and from multiple locations. It never happens in Chrome/Safari.

https://ov1.flamingtext.com/a2.html

Load the above page, if you see "CoolLogo.com" then the bug has shown itself. If it doesn't happen, reload.

What is crazy is that it only happens for these ov10 and ov11 machines, and they get the other's ip.


I know what you are thinking, it's my DNS or something odd about my setup. Either on the client or server. But I believe I've eliminated that possibility. I'm still suspicious that we are doing something wrong, but when I see the wrong IP address in the dev tool, I'm not sure where else to look.

geoipdns config (authorative dns is ns1/ns2/n3.registerbot.com which I control). +ov10-engine.flamingtext.com:51.79.78.56:1200 #ov10 +ov11-engine.flamingtext.com:51.79.78.58:1200 #ov11 (there are no other entries), and true for all three name servers.

confirmed with dig, nslookup and ping. from multiple locations around the world. with at least 5 different ISP's. There are no entries in my /etc/hosts. The ip address is always correct. It's only wrong in firefox.

Any ideas?

Cameron

Tất cả các câu trả lời (10)

more options

https://ov1.flamingtext.com/wrong-ip.png

shows that firefox has the wrong ip address!

(I couldn't upload the image as it kept erroring)

Cameron

Hữu ích?

more options

Is this with all websites/pages, some, a few?

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Hữu ích?

more options

Sorry, I should have explained that flamingtext.com is my site.

But I haven't seen this anywhere else.

Thanks, I tried safe-mode, private window, disabling hardware accelleration, and in (safe-mode and private and hardware disabled) etc.. doesn't help.

I don't see how it could be cookie related. Because if you can set a cookie to get a host to have the wrong ip address, then that is a big security hole.

The only allowable cache issue that also isn't a huge security hole, would be if we changed IP addresses recently and it was getting the old one. But that's also not true. It has never changed.

We are a largish site, with some good technical ability, but I don't discount missing something easy.

So you see the issue when you load the page?

thanks,

Cameron

Hữu ích?

more options

It now strikes me that the ip addresses for ov10/11 are also used for the main site: 51.79.78.56 51.79.78.58

they are part of the round robin DNS for flamingtext.com, so I'm a bit more suspicious that it's a firefox bug.

cheers,

Cameron

  1. please note that it is a geo dns server, so this is the answer in the US:

[cameron@flash ~]$ dig flamingtext.com

...

ANSWER SECTION:

flamingtext.com. 863 IN A 192.95.37.78 flamingtext.com. 863 IN A 198.50.158.213 flamingtext.com. 863 IN A 192.95.16.211 flamingtext.com. 863 IN A 51.79.78.56 flamingtext.com. 863 IN A 51.79.78.58

Hữu ích?

more options

I called for more help.

Hữu ích?

more options

thank you.

Hữu ích?

more options

I had to disable the test, and hack my way around the problem. Please let me know if someone wants to look into this, and I'll re-enable.

Cameron note to self: re-able gimp engines on ov10, ov11 to see the problem in a2.html

Hữu ích?

more options

Did you check the various sections on the about:networking page ?

Hữu ích?

more options

Perhaps you could be more specific. What am I looking for here?

But if you get the way networking and caching happens, you'll be suspicious from the following: about:networking#dns just showing the relevant rows and removed expires to make easier to read:

Hostname                  Family   TRR Addresses
flamingtext.com             ipv4 false 51.79.78.56
                                       51.79.78.58
ov11-engine.flamingtext.com ipv4 false 51.79.78.58
ov10-engine.flamingtext.com ipv4 false 51.79.78.56


and ov11-engine.flamingtext.com regularly gets the .56 ip address. Crazy right! see screen shot earlier. You can test it yourself. The above test (https://ov1.flamingtext.com/a2.html) fails for everybody, nearly every time. I'll leave the test up for 24 hours, unless someone seriously wants to look at the problem.

Cameron

Được chỉnh sửa bởi blokecom vào

Hữu ích?

more options

Sorry, retry formating:

Hostname                  Family   TRR Addresses
flamingtext.com             ipv4 false 51.79.78.56
                                       51.79.78.58
ov11-engine.flamingtext.com ipv4 false 51.79.78.58
ov10-engine.flamingtext.com ipv4 false 51.79.78.56

Hữu ích?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.