Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Even with all extensions and plug-uns disabled, cannot play YouTube (either imbeded or from URL link)

  • 6 trả lời
  • 1 gặp vấn đề này
  • 4 lượt xem
  • Trả lời mới nhất được viết bởi cwaters1

more options

For several weeks I have been unable to play any YouTube video, either embedded or as a direct URLlink. Firefox support articles only suggest removing all plug-ins/extensions and then adding back one-at-a-time to find the offending one but I've disabled ALL plug-ins and extensions without any effect. Using Firefox 76.0.1, but I've had the same problem with the two previous versions also. All I get in a YouTube video is a black screen with a spinning circle. The same videos play fine in Chrome (which I hate to use - I'm a committed Firefox user!). I've also turned off tracking protections for YouTube - there's simply nothing left to disable! FWIW - only using Windows Defender as security, and there is nothing in it's log either. I'd sure appreciate a solution if one exists! CHW - Omaha

Giải pháp được chọn

Hi CHW, I set this tab aside to come back to and lost track of it. Sorry about that.

Since you have a progress circle, I had assumed this was not an autoplay problem, but just in case, does it make any difference to click pause and then click play again?

I have embedded videos in two of my pages, one from YouTube and one from Vimeo. Neither of these attempts to autoplay, so that shouldn't be a factor. Are they both broken?

Đọc câu trả lời này trong ngữ cảnh 👍 0

All Replies (6)

more options

Hi CHW, could you look at the following test page and see whether it gives positive results in detecting video capabilities in your Firefox:

https://www.jeffersonscher.com/sumo/html5-video.html

Google uses a lot of different servers, including numerous servers with names like https://r5---sn-n4v7knll.googlevideo.com for the actual bits and pieces of the video. So you may want to check out the Network Monitor tool to see whether those requests are succeeding or failing.

To open the Network Monitor in the lower part of the tab, you can use either:

  • "3-bar" menu button > Web Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (Windows) Ctrl+Shift+e

When you click the Play button, Firefox should start listing all the files it is requesting, along with information about whether the request was successful. Do you notice any obvious failures?

More info on this tool: https://developer.mozilla.org/docs/Tools/Network_Monitor

Helpful?

more options

Thanks for your advise - and sorry for the delayed response to it. 1) I couldn't make any sense of the Network Monitor results: I saw no obvious failures, but there's a lot of stuff in small print at the bottom of the screen I have to scroll through and could have missed something. 2) The test page you recommended looks OK - I think. I've attached a screen shot of it. 3) With a lot of trials I've determined it's not JUST YouTube videos (embedded or direct to their URL) but embedded videos in other web sites, e.g. The WSJ videos, that won't play either. And, curiously, they seem to be LOADING, but not PLAYING. I can hover over the horizontal bar at the bottom of a video player's screen and see still pictures of the entire video. I've attached a snip of what I'm referring to (you can't see my cursor, but I'm hovering above the 6:25 minute point). Does this help any? CHW

Helpful?

more options

Giải pháp được chọn

Hi CHW, I set this tab aside to come back to and lost track of it. Sorry about that.

Since you have a progress circle, I had assumed this was not an autoplay problem, but just in case, does it make any difference to click pause and then click play again?

I have embedded videos in two of my pages, one from YouTube and one from Vimeo. Neither of these attempts to autoplay, so that shouldn't be a factor. Are they both broken?

Helpful?

more options

As it turns out, I found the simple solution on a GOOGLE search, NOT from the Mozilla forum and help files: just turn off the "Performance - use recommended settings" in order to turn off the "use hardware acceleration when available" (which is not a separate option to turn off). Evidently the Performance setting was automatically changed to 'checked' with one of the recent updates, or began misbehaving after an update (I didn't change it anyway). So I'm good to go, but this solution should appear high-up on the responses to video playing problems, and not be found only in a Google search. Thank you for your help and interest in my problem

Helpful?

more options

Hmm, usually hardware acceleration is not a problem on newer systems.

Since hardware acceleration improves the appearance of fonts and animations, you may want to check whether graphics card/chipset driver updates are available for your system. This article suggests safe ways to do that: Upgrade your graphics drivers to use hardware acceleration and WebGL.

Helpful?

more options

I should have noted that this was originally a Windows Vista 7 laptop that I upgraded (during the brief period of free updates) to Windows 10 - it must be at least 12 years old, but with updated memory and a Core i7 processor, it's all I need (it does NOT have a separate graphics card, either). I run at startup Intel's "Driver and Support Assistant" which shows everything is up to date, but Intel/Toshiba (authors of the graphics driver) have long since quit updating drivers for such legacy hardware. Firefox must detect it's a much newer PC, however and default to the "recommended performance settings" it thinks I should use. BTW - it has a 750GB hard drive that I clone monthly - due to MTBF concerns - so I'm ready for it's natural death - and resurrection. CHW

Helpful?

Đặt một câu hỏi

Bạn phải đăng nhập vào tài khoản của bạn để trả lời bài viết. Vui lòng bắt đầu một câu hỏi mới, nếu bạn chưa có tài khoản.